You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     amd...@freebsd.org
Last committer: jbe...@freebsd.org
Ident:          $FreeBSD: head/games/valyriatear/Makefile 459315 2018-01-18 
04:11:02Z jbeich $
Log URL:        
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p464333_s330823/logs/valyriatear-1.0.0_3.log
Build URL:      
http://beefy12.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p464333_s330823
Log:

=>> Building games/valyriatear
build started at Wed Mar 14 06:07:47 UTC 2018
port directory: /usr/ports/games/valyriatear
package name: valyriatear-1.0.0_3
building for: FreeBSD head-amd64-default-job-05 12.0-CURRENT FreeBSD 
12.0-CURRENT 1200060 amd64
maintained by: amd...@freebsd.org
Makefile ident:      $FreeBSD: head/games/valyriatear/Makefile 459315 
2018-01-18 04:11:02Z jbeich $
Poudriere version: 3.2.5-3-gef344f26
Host OSVERSION: 1200059
Jail OSVERSION: 1200060
Job Id: 05




!!! Jail is newer than host. (Jail: 1200060, Host: 1200059) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1200060
UNAME_v=FreeBSD 12.0-CURRENT 1200060
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.5-3-gef344f26
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for valyriatear-1.0.0_3:
     DOCS=on: Build and/or install documentation
     EDITOR=off: Compile the Qt editor along with the game
     NLS=on: Native Language Support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
amd...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/valyriatear/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/valyriatear/work  
HOME=/wrkdirs/usr/ports/games/valyriatear/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/games/valyriatear/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config LUA_MODLIBDIR=/usr/local/lib/lua/5.1  
LUA_MODSHAREDIR=/usr/local/share/lua/5.1  LUA_VER=5.1  
LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/valyriatear/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/valyriatear/work  
HOME=/wrkdirs/usr/ports/games/valyriatear/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/games/valyriatear/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
DESTDIR=/wrkdirs/usr/ports/games/valyriatear/work/stage PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-DLIBICONV_PLUG"  LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  
-DLIBICONV_PLUG"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="insta
 ll  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" PORTEXAMPLES="" DOCS="" NO_DOCS="@comment " EDITOR="@comment " 
NO_EDITOR="" NLS="" NO_NLS="@comment " CMAKE_BUILD_TYPE="release" 
LUA_MODLIBDIR=lib/lua/5.1  LUA_MODSHAREDIR=share/lua/5.1  LUA_VER=5.1  
LUA_INCDIR=include/lua51  LUA_LIBDIR=lib  LUA_VER_STR=51 GTK2_VERSION="2.10.0"  
GTK3_VERSION="3.0.0" OSREL=12.0 PREFIX=%D LOCALBASE=/usr/local  
RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/valyriatear"  
EXAMPLESDIR="share/examples/valyriatear"  DATADIR="share/valyriatear"  
WWWDIR="www/valyriatear"  ETCDIR="etc/valyriatear"
--End PLIST_SUB--

--SUB_LIST--
DOCS="" NO_DOCS="@comment " EDITOR="@comment " NO_EDITOR="" NLS="" 
NO_NLS="@comment " PREFIX=/usr/local LOCALBASE=/usr/local  
DATADIR=/usr/local/share/valyriatear DOCSDIR=/usr/local/share/doc/valyriatear 
EXAMPLESDIR=/usr/local/share/examples/valyriatear  
WWWDIR=/usr/local/www/valyriatear ETCDIR=/usr/local/etc/valyriatear
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) 
(based on LLVM 6.0.0) Target: x86_64-unknown-freebsd12.0 Thread model: posix 
InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 
326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd12.0 Thread model: 
posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
OUTPUT_58173849_921dbbb2=yes
OUTPUT_9bdba57c_921dbbb2=yes
OUTPUT_6a4fe7f5_921dbbb2=yes
OUTPUT_6bcac02b_921dbbb2=yes
OUTPUT_67d20829_921dbbb2=yes
OUTPUT_bfa62e83_921dbbb2=yes
OUTPUT_f0b4d593_921dbbb2=yes
OUTPUT_308abb44_921dbbb2=yes
OUTPUT_f00456e5_921dbbb2=yes
OUTPUT_65ad290d_921dbbb2=yes
OUTPUT_b2657cc3_921dbbb2=yes
OUTPUT_380987f7_921dbbb2=yes
ARCH=amd64
OPSYS=FreeBSD
_OSRELEASE=12.0-CURRENT
OSREL=12.0
OSVERSION=1200060
PYTHONBASE=/usr/local
HAVE_COMPAT_IA32_KERN=YES
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   valyriatear-1.0.0_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.5.txz
[head-amd64-default-job-05] Installing pkg-1.10.5...
[head-amd64-default-job-05] Extracting pkg-1.10.5: .......... done
===>   valyriatear-1.0.0_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of valyriatear-1.0.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by valyriatear-1.0.0_3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by valyriatear-1.0.0_3 for building
=> SHA256 Checksum OK for Bertram25-ValyriaTear-1.0.0-1.0.0-gcc5_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by valyriatear-1.0.0_3 for building
===>  Extracting for valyriatear-1.0.0_3
=> SHA256 Checksum OK for Bertram25-ValyriaTear-1.0.0-1.0.0-gcc5_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for valyriatear-1.0.0_3
===>  Applying FreeBSD patches for valyriatear-1.0.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   valyriatear-1.0.0_3 depends on file: /usr/local/bin/sdl-config - not 
found
===>   Installing existing package /packages/All/sdl-1.2.15_10,2.txz
[head-amd64-default-job-05] Installing sdl-1.2.15_10,2...
[head-amd64-default-job-05] `-- Installing aalib-1.4.r5_11...
[head-amd64-default-job-05] |   `-- Installing indexinfo-0.3.1...
[head-amd64-default-job-05] |   `-- Extracting indexinfo-0.3.1: .... done
[head-amd64-default-job-05] `-- Extracting aalib-1.4.r5_11: .......... done
[head-amd64-default-job-05] `-- Installing libGLU-9.0.0_3...
[head-amd64-default-job-05] |   `-- Installing mesa-libs-17.3.1...
[head-amd64-default-job-05] |   | `-- Installing expat-2.2.5...
<snip>
[head-amd64-default-job-05] Extracting dri3proto-1.0: ...... done
===>   valyriatear-1.0.0_3 depends on file: 
/usr/local/libdata/pkgconfig/dri3proto.pc - found
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on file: 
/usr/local/libdata/pkgconfig/glproto.pc - found
===>   valyriatear-1.0.0_3 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   valyriatear-1.0.0_3 depends on file: 
/usr/local/libdata/pkgconfig/dri3proto.pc - found
===>   valyriatear-1.0.0_3 depends on file: /usr/local/libdata/pkgconfig/x11.pc 
- found
===>   valyriatear-1.0.0_3 depends on file: 
/usr/local/libdata/pkgconfig/xext.pc - found
===>   valyriatear-1.0.0_3 depends on file: /usr/local/libdata/pkgconfig/sm.pc 
- found
===>   valyriatear-1.0.0_3 depends on file: /usr/local/libdata/pkgconfig/ice.pc 
- found
===========================================================================
=======================<phase: lib-depends    >============================
===>   valyriatear-1.0.0_3 depends on shared library: libboost_thread.so - not 
found
===>   Installing existing package /packages/All/boost-libs-1.66.0.txz
[head-amd64-default-job-05] Installing boost-libs-1.66.0...
[head-amd64-default-job-05] `-- Installing icu-60.2_2,1...
[head-amd64-default-job-05] `-- Extracting icu-60.2_2,1: .......... done
[head-amd64-default-job-05] Extracting boost-libs-1.66.0: .......... done
Message from boost-libs-1.66.0:

You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   valyriatear-1.0.0_3 depends on shared library: libboost_thread.so - 
found (/usr/local/lib/libboost_thread.so)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: libvorbis.so - not found
===>   Installing existing package /packages/All/libvorbis-1.3.5_1,3.txz
[head-amd64-default-job-05] Installing libvorbis-1.3.5_1,3...
[head-amd64-default-job-05] `-- Installing libogg-1.3.3,4...
[head-amd64-default-job-05] `-- Extracting libogg-1.3.3,4: .......... done
[head-amd64-default-job-05] Extracting libvorbis-1.3.5_1,3: .......... done
===>   valyriatear-1.0.0_3 depends on shared library: libvorbis.so - found 
(/usr/local/lib/libvorbis.so)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: libpng.so - found 
(/usr/local/lib/libpng.so)
===>   valyriatear-1.0.0_3 depends on shared library: libSDL.so - found 
(/usr/local/lib/libSDL.so)
===>   valyriatear-1.0.0_3 depends on shared library: libSDL_image.so - not 
found
===>   Installing existing package /packages/All/sdl_image-1.2.12_11.txz
[head-amd64-default-job-05] Installing sdl_image-1.2.12_11...
[head-amd64-default-job-05] `-- Installing webp-0.6.1...
[head-amd64-default-job-05] |   `-- Installing giflib-5.1.4...
[head-amd64-default-job-05] |   `-- Extracting giflib-5.1.4: .......... done
[head-amd64-default-job-05] `-- Extracting webp-0.6.1: .......... done
[head-amd64-default-job-05] Extracting sdl_image-1.2.12_11: .......... done
===>   valyriatear-1.0.0_3 depends on shared library: libSDL_image.so - found 
(/usr/local/lib/libSDL_image.so)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: libSDL_ttf.so - not found
===>   Installing existing package /packages/All/sdl_ttf-2.0.11_7.txz
[head-amd64-default-job-05] Installing sdl_ttf-2.0.11_7...
[head-amd64-default-job-05] Extracting sdl_ttf-2.0.11_7: .......... done
===>   valyriatear-1.0.0_3 depends on shared library: libSDL_ttf.so - found 
(/usr/local/lib/libSDL_ttf.so)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: liblua-5.1.so - not found
===>   Installing existing package /packages/All/lua51-5.1.5_9.txz
[head-amd64-default-job-05] Installing lua51-5.1.5_9...
[head-amd64-default-job-05] `-- Installing libedit-3.1.20170329_2,1...
[head-amd64-default-job-05] `-- Extracting libedit-3.1.20170329_2,1: .......... 
done
[head-amd64-default-job-05] Extracting lua51-5.1.5_9: ......... done
===>   valyriatear-1.0.0_3 depends on shared library: liblua-5.1.so - found 
(/usr/local/lib/liblua-5.1.so)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: libopenal.so.1 - not found
===>   Installing existing package /packages/All/openal-soft-1.18.2.txz
[head-amd64-default-job-05] Installing openal-soft-1.18.2...
[head-amd64-default-job-05] Extracting openal-soft-1.18.2: .......... done
Message from openal-soft-1.18.2:

===>   NOTICE:

The openal-soft port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   valyriatear-1.0.0_3 depends on shared library: libopenal.so.1 - found 
(/usr/local/lib/libopenal.so.1)
===>   Returning to build of valyriatear-1.0.0_3
===>   valyriatear-1.0.0_3 depends on shared library: libintl.so - found 
(/usr/local/lib/libintl.so)
===>   valyriatear-1.0.0_3 depends on shared library: libatk-1.0.so - found 
(/usr/local/lib/libatk-1.0.so)
===>   valyriatear-1.0.0_3 depends on shared library: libgdk_pixbuf-2.0.so - 
found (/usr/local/lib/libgdk_pixbuf-2.0.so)
===>   valyriatear-1.0.0_3 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   valyriatear-1.0.0_3 depends on shared library: libintl.so - found 
(/usr/local/lib/libintl.so)
===>   valyriatear-1.0.0_3 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===>   valyriatear-1.0.0_3 depends on shared library: libGLU.so - found 
(/usr/local/lib/libGLU.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for valyriatear-1.0.0_3
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/games/valyriatear/work/ValyriaTear-1.0.0-gcc5
-- The C compiler identification is Clang 6.0.0
-- The CXX compiler identification is Clang 6.0.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Found Threads: TRUE  
-- Found SDL: /usr/local/lib/libSDLmain.a;/usr/local/lib/libSDL.so;-pthread  
-- Found SDL_ttf: /usr/local/lib/libSDL_ttf.so (found version "2.0.11") 
-- Found SDL_image: /usr/local/lib/libSDL_image.so (found version "1.2.12") 
-- Found OpenGL: /usr/local/lib/libGL.so   
-- Found OpenAL: /usr/local/lib/libopenal.so  
-- Found VORBISFILE: 
optimized;/usr/local/lib/libvorbisfile.so;debug;/usr/local/lib/libvorbisfile.so 
 
-- Found Lua51: /usr/local/lib/liblua-5.1.so;/usr/lib/libm.so (found version 
"5.1.5") 
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.11") 
-- Found PNG: /usr/local/lib/libpng.so (found version "1.6.34+apng") 
-- Found Gettext: /usr/local/bin/msgmerge (found version "0.19.8.1") 
-- Boost version: 1.66.0
-- Build type: Release
-- l10n support enabled
-- Found libintl: /usr/local/lib/libintl.so
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/local/lib/libX11.so
-- Using included luabind files
-- Configured luabind information file...
CMake Warning (dev) at po/CMakeLists.txt:100 (ADD_CUSTOM_TARGET):
  Policy CMP0037 is not set: Target names should not be reserved and should
  match a validity pattern.  Run "cmake --help-policy CMP0037" for policy
  details.  Use the cmake_policy command to set the policy and suppress this
  warning.

  The target name "update-translation-en@quot" is reserved or not valid for
  certain CMake features, such as generator expressions, and may result in
  undefined behavior.
Call Stack (most recent call first):
  po/CMakeLists.txt:125 (VALYRIATEAR_GETTEXT_UPDATE_PO)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_COLOR_MAKEFILE
    CMAKE_CXX_FLAGS_DEBUG
    CMAKE_C_FLAGS_DEBUG
    CMAKE_C_FLAGS_RELEASE
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_SHARED_LINKER_FLAGS
    CMAKE_VERBOSE_MAKEFILE
    ICONV_INCLUDE_DIR
    ICONV_LIBRARIES
    ICONV_LIBRARY
    LIBICONV_INCLUDE_DIR
    LIBICONV_LIBRARIES
    LIBICONV_LIBRARY


-- Build files have been written to: 
/wrkdirs/usr/ports/games/valyriatear/work/ValyriaTear-1.0.0-gcc5
===========================================================================
=======================<phase: build          >============================
===>  Building for valyriatear-1.0.0_3
[1/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global.cpp.o -c 
src/common/global/global.cpp
[2/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global_actors.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global_actors.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global_actors.cpp.o -c 
src/common/global/global_actors.cpp
[3/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global_effects.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global_effects.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global_effects.cpp.o -c 
src/common/global/global_effects.cpp
[4/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global_objects.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global_objects.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global_objects.cpp.o -c 
src/common/global/global_objects.cpp
[5/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global_skills.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global_skills.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global_skills.cpp.o -c 
src/common/global/global_skills.cpp
[6/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/global/global_utils.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/global/global_utils.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/global/global_utils.cpp.o -c 
src/common/global/global_utils.cpp
[7/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/gui/option.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/gui/option.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/gui/option.cpp.o -c 
src/common/gui/option.cpp
[8/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/gui/menu_window.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/gui/menu_window.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/gui/menu_window.cpp.o -c 
src/common/gui/menu_window.cpp
[9/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/gui/textbox.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/gui/textbox.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/gui/textbox.cpp.o -c 
src/common/gui/textbox.cpp
[10/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/gui/gui.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/gui/gui.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/gui/gui.cpp.o -c src/common/gui/gui.cpp
[11/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/message_window.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/message_window.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/message_window.cpp.o -c 
src/common/message_window.cpp
[12/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/dialogue.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/dialogue.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/dialogue.cpp.o -c src/common/dialogue.cpp
[13/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/common.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/common.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/common.cpp.o -c src/common/common.cpp
[14/120] /usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o -c 
src/common/options_handler.cpp
FAILED: src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o 
/usr/bin/c++   -I/usr/local/include -Isrc -I/usr/local/include/SDL 
-I/usr/local/include/AL -I/usr/local/include/lua51 -Isrc/luabind -O2 -pipe 
-DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG -O2 
-pipe -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -DLIBICONV_PLUG   
-DPACKAGE_VERSION=\"0.1.0\" -DPKG_DATADIR=\"/usr/local/share/valyriatear/\" 
-DLOCALEDIR=\"/usr/local/share/locale/\" -DPKG_NAME=\"valyriatear/\" -DUSE_X11 
-MD -MT src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o -MF 
src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o.d -o 
src/CMakeFiles/valyriatear.dir/common/options_handler.cpp.o -c 
src/common/options_handler.cpp
src/common/options_handler.cpp:621:65: error: invalid suffix on literal; C++11 
requires a space between literal and identifier 
[-Wreserved-user-defined-literal]
                std::string mo_filename = lang + 
"/LC_MESSAGES/"APPSHORTNAME".mo";
                                                                ^
                                                                 
1 error generated.
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make: stopped in /usr/ports/games/valyriatear
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to