You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     r...@freebsd.org
Last committer: sunp...@freebsd.org
Ident:          $FreeBSD: branches/2018Q2/devel/rubygem-ffi/Makefile 435405 
2017-03-04 13:49:07Z sunpoet $
Log URL:        
http://beefy14.nyi.freebsd.org/data/111mips-quarterly/466761/logs/rubygem-ffi-1.9.18.log
Build URL:      
http://beefy14.nyi.freebsd.org/build.html?mastername=111mips-quarterly&build=466761
Log:

=>> Building devel/rubygem-ffi
build started at Sun Apr  8 01:09:20 UTC 2018
port directory: /usr/ports/devel/rubygem-ffi
package name: rubygem-ffi-1.9.18
building for: FreeBSD 111mips-quarterly-job-11 11.1-RELEASE-p6 FreeBSD 
11.1-RELEASE-p6 1101001 mips
maintained by: r...@freebsd.org
Makefile ident:      $FreeBSD: branches/2018Q2/devel/rubygem-ffi/Makefile 
435405 2017-03-04 13:49:07Z sunpoet $
Poudriere version: 3.2.6-1-ga0ae87a0
Host OSVERSION: 1200060
Jail OSVERSION: 1101001
Job Id: 11

---Begin Environment---
POUDRIEREPATH=/usr/local/bin/poudriere
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
OLDPWD=/usr/local/poudriere/data/.m/111mips-quarterly/ref/.p
SCRIPTPREFIX=/usr/local/share/poudriere
MASTERNAME=111mips-quarterly
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
PWD=/usr/local/poudriere/data/.m/111mips-quarterly/ref/.p/pool
SAVED_TERM=
PACKAGE_BUILDING=yes
POUDRIERE_BUILD_TYPE=bulk
MASTERMNT=/usr/local/poudriere/data/.m/111mips-quarterly/ref
POUDRIERE_VERSION=3.2.6-1-ga0ae87a0
LIBEXECPREFIX=/usr/local/libexec/poudriere
USER=root
QEMU_EMULATING=1
LOCALBASE=/usr/local
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
HOME=/root
STATUS=1
MAIL=/var/mail/root
BLOCKSIZE=K
UNAME_r=11.1-RELEASE-p6
UNAME_v=FreeBSD 11.1-RELEASE-p6 1101001
OSVERSION=1101001
ABI_FILE=/usr/lib/crt1.o
UNAME_m=mips
UNAME_p=mips
SHELL=/bin/csh
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
r...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/rubygem-ffi/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-ffi/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/rubygem-ffi/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0  
-fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" 
LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" PORTEXAMPLES="" RUBY_LIBDIR="lib/ruby/2.4" 
RUBY_ARCHLIBDIR="lib/ruby/2.4/mips-freebsd11" 
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.4" 
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.4/mips-freebsd11" 
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.4" 
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.4/mips-freebsd11" 
RUBY_MODDOCDIR="share/doc/ruby24/ffi" 
RUBY_MODEXAMPLESDIR="share/examples/ruby24/ffi" RUBY_DOCDIR="share/doc/ruby24" 
RUBY_EXAMPLESDIR="share/examples/ruby24" RUBY_RIDIR="share/ri/2.4/system" 
RUBY_SITERIDIR="share/ri/2.4/site"  RUBY_VERSION="2.4.3"  RUBY_VER="2.4"  
RUBY_SHLIBVER="24"  RUBY_ARCH="mips-freebsd11"  RUBY_SUFFIX="24"  
RUBY_NAME="ruby24"  RUBY_DEFAULT_SUFFIX="24"  RUBY23="@comment "  RUBY24=""  
RUBY25="@comment " PORTVERSION="1.9.18"  REV=""  
GEMS_BASE_DIR="lib/ruby/gems/2.4"  GEMS_DIR="lib/ruby/gems/2.4/gems"  
DOC_DIR="lib/ruby/gems/2.4/doc"  CACHE_DIR="lib/ruby/gems/2.4/cache"  
SPEC_DIR="lib/ruby/gems/2.4/specifications"  
EXT_DIR="lib/ruby/gems/2.4/extensions"  PORT=
 "ffi-1.9.18"  GEM_NAME="ffi-1.9.18"  
GEM_LIB_DIR="lib/ruby/gems/2.4/gems/ffi-1.9.18"  
GEM_DOC_DIR="lib/ruby/gems/2.4/doc/ffi-1.9.18"  
GEM_SPEC="lib/ruby/gems/2.4/specifications/ffi-1.9.18.gemspec"  
GEM_CACHE="lib/ruby/gems/2.4/cache/ffi-1.9.18.gem"  EXTRACT_SUFX=".gem" 
OSREL=11.1 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/ffi"  EXAMPLESDIR="share/examples/ffi"  DATADIR="share/ffi"  
WWWDIR="www/ffi"  ETCDIR="etc/ffi"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/ffi 
DOCSDIR=/usr/local/share/doc/ffi EXAMPLESDIR=/usr/local/share/examples/ffi  
WWWDIR=/usr/local/www/ffi ETCDIR=/usr/local/etc/ffi
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=mips
MACHINE_ARCH=mips
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 
2007 Free Software Foundation, Inc. This is free software; see the source for 
copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=Using built-in specs. Target: mips-undermydesk-freebsd 
Configured with: FreeBSD/mips system compiler Thread model: posix gcc version 
4.2.1 20070831 patched [FreeBSD] "/usr/bin/ld" "--eh-frame-hdr" "-EB" "-EB" 
"-melf32btsmip_fbsd" "--enable-new-dtags" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "/usr/lib/crt1.o" "/usr/lib/crti.o" 
"/usr/lib/crtbegin.o" "-L/usr/lib" "-L/usr/lib" "/dev/null" "-lstdc++" "-lm" 
"-lgcc_s" "-lgcc" "-lc" "-lgcc_s" "-lgcc" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=cc1: error: unrecognized command line option 
"-std=c11"
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=cc1: error: unrecognized command line option 
"-std=gnu11"
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=cc1plus: error: unrecognized command line option 
"-std=c++0x"
CC_OUTPUT_9d218390_f00456e5=cc1plus: error: unrecognized command line option 
"-std=c++11"
CC_OUTPUT_9d218390_65ad290d=cc1plus: error: unrecognized command line option 
"-std=c++14"
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=cc1plus: error: unrecognized command line option 
"-std=gnu++11"
_OBJC_CCVERSION_9d218390=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright 
(C) 2007 Free Software Foundation, Inc. This is free software; see the source 
for copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_OBJC_ALTCCVERSION_9d218390=none
ARCH=mips
OPSYS=FreeBSD
_OSRELEASE=11.1-RELEASE-p6
OSREL=11.1
OSVERSION=1101001
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  131072
stack size              (kbytes, -s)  8192
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.5.txz
[111mips-quarterly-job-11] Installing pkg-1.10.5...
[111mips-quarterly-job-11] Extracting pkg-1.10.5: .......... done
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rubygem-ffi-1.9.18
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-ffi-1.9.18 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-ffi-1.9.18 for building
=> SHA256 Checksum OK for rubygem/ffi-1.9.18.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/ruby24 - not found
===>   Installing existing package /packages/All/ruby-2.4.3,1.txz
[111mips-quarterly-job-11] Installing ruby-2.4.3,1...
[111mips-quarterly-job-11] `-- Installing libedit-3.1.20170329_2,1...
[111mips-quarterly-job-11] `-- Extracting libedit-3.1.20170329_2,1: .......... 
done
[111mips-quarterly-job-11] `-- Installing libffi-3.2.1_2...
[111mips-quarterly-job-11] |   `-- Installing indexinfo-0.3.1...
[111mips-quarterly-job-11] |   `-- Extracting indexinfo-0.3.1: .... done
[111mips-quarterly-job-11] `-- Extracting libffi-3.2.1_2: .......... done
[111mips-quarterly-job-11] `-- Installing libyaml-0.1.6_2...
[111mips-quarterly-job-11] `-- Extracting libyaml-0.1.6_2: ......... done
[111mips-quarterly-job-11] Extracting ruby-2.4.3,1: .......... done
Message from ruby-2.4.3,1:

====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/ruby24 - found
===>   Returning to build of rubygem-ffi-1.9.18
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/gem24 - not found
===>   Installing existing package /packages/All/ruby24-gems-2.7.6.txz
[111mips-quarterly-job-11] Installing ruby24-gems-2.7.6...
[111mips-quarterly-job-11] Extracting ruby24-gems-2.7.6: .......... done
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/gem24 - found
===>   Returning to build of rubygem-ffi-1.9.18
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-ffi-1.9.18 for building
===>  Extracting for rubygem-ffi-1.9.18
=> SHA256 Checksum OK for rubygem/ffi-1.9.18.gem.
Unpacked gem: '/wrkdirs/usr/ports/devel/rubygem-ffi/work/ffi-1.9.18'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/ruby24 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-ffi-1.9.18
===>  Applying FreeBSD patches for rubygem-ffi-1.9.18
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/ruby24 - found
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/gem24 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   rubygem-ffi-1.9.18 depends on shared library: libffi.so - found 
(/usr/local/lib/libffi.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-ffi-1.9.18
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/rubygem-ffi/work/ffi-1.9.18/ext/ffi_c/libffi/m4/libtool.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/rubygem-ffi/work/ffi-1.9.18/ext/ffi_c/libffi/configure
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-ffi-1.9.18
  Successfully built RubyGem
  Name: ffi
  Version: 1.9.18
  File: ffi-1.9.18.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/ruby24 - found
===>   rubygem-ffi-1.9.18 depends on file: /usr/local/bin/gem24 - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for rubygem-ffi-1.9.18
===>   Generating temporary packing list
(cd /wrkdirs/usr/ports/devel/rubygem-ffi/work/ffi-1.9.18; /usr/bin/env 
RB_USER_INSTALL=yes LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 /usr/local/bin/gem24 
install -l --no-update-sources --install-dir 
/wrkdirs/usr/ports/devel/rubygem-ffi/work/stage/usr/local/lib/ruby/gems/2.4 
--ignore-dependencies 
--bindir=/wrkdirs/usr/ports/devel/rubygem-ffi/work/stage/usr/local/bin --rdoc 
--ri ffi-1.9.18.gem -- --build-args )
Building native extensions with: '--build-args'
This could take a while...
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require': cannot load such file -- json/pure (LoadError)
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require'
        from /usr/local/lib/ruby/2.4/json.rb:61:in `rescue in <module:JSON>'
        from /usr/local/lib/ruby/2.4/json.rb:58:in `<module:JSON>'
        from /usr/local/lib/ruby/2.4/json.rb:55:in `<top (required)>'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require'
        from /usr/local/lib/ruby/2.4/rdoc/generator/json_index.rb:2:in `<top 
(required)>'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:59:in 
`require'
        from /usr/local/lib/ruby/2.4/rdoc/generator/darkfish.rb:176:in 
`initialize'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:125:in `new'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:125:in `document'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:196:in `generate'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:56:in `block in 
generation_hook'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:55:in `each'
        from /usr/local/lib/ruby/2.4/rdoc/rubygems_hook.rb:55:in 
`generation_hook'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:242:in 
`block in install_gem_without_dependencies'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:241:in 
`each'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:241:in 
`install_gem_without_dependencies'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:191:in 
`install_gem'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:255:in 
`block in install_gems'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:251:in 
`each'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:251:in 
`install_gems'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/commands/install_command.rb:158:in 
`execute'
        from /usr/local/lib/ruby/site_ruby/2.4/rubygems/command.rb:313:in 
`invoke_with_build_args'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/command_manager.rb:171:in 
`process_args'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/command_manager.rb:141:in `run'
        from /usr/local/lib/ruby/site_ruby/2.4/rubygems/gem_runner.rb:59:in 
`run'
        from /usr/local/bin/gem24:21:in `<main>'
Successfully installed ffi-1.9.18
Parsing documentation for ffi-1.9.18
Installing ri documentation for ffi-1.9.18
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/rubygem-ffi
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to