You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     l...@freebsd.org
Last committer: lini...@freebsd.org
Ident:          $FreeBSD: head/games/jaggedalliance2/Makefile 456894 2017-12-21 
08:59:33Z linimon $
Log URL:        
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p467547_s332632/logs/ja2-0.14.01.log
Build URL:      
http://beefy12.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p467547_s332632
Log:

=>> Building games/jaggedalliance2
build started at Tue Apr 17 01:39:07 UTC 2018
port directory: /usr/ports/games/jaggedalliance2
package name: ja2-0.14.01
building for: FreeBSD head-amd64-default-job-02 12.0-CURRENT FreeBSD 
12.0-CURRENT 1200062 amd64
maintained by: l...@freebsd.org
Makefile ident:      $FreeBSD: head/games/jaggedalliance2/Makefile 456894 
2017-12-21 08:59:33Z linimon $
Poudriere version: 3.2.6-1-ga0ae87a0
Host OSVERSION: 1200060
Jail OSVERSION: 1200062
Job Id: 02




!!! Jail is newer than host. (Jail: 1200062, Host: 1200060) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1200062
UNAME_v=FreeBSD 12.0-CURRENT 1200062
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.6-1-ga0ae87a0
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
l...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--prefix=/usr/local
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config MAKE=gmake 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work  
HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/games/jaggedalliance2/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
Q= SDL_CONFIG=/usr/local/bin/sdl-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work  
HOME=/wrkdirs/usr/ports/games/jaggedalliance2/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/games/jaggedalliance2/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  
LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" PORTEXAMPLES="" OSREL=12.0 PREFIX=%D LOCALBASE=/usr/local  
RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/ja2"  
EXAMPLESDIR="share/examples/ja2"  DATADIR="share/ja2"  WWWDIR="www/ja2"  
ETCDIR="etc/ja2"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/ja2 
DOCSDIR=/usr/local/share/doc/ja2 EXAMPLESDIR=/usr/local/share/examples/ja2  
WWWDIR=/usr/local/www/ja2 ETCDIR=/usr/local/etc/ja2
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) 
(based on LLVM 6.0.0) Target: x86_64-unknown-freebsd12.0 Thread model: posix 
InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 
326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd12.0 Thread model: 
posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 
326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd12.0 Thread model: 
posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=amd64
OPSYS=FreeBSD
_OSRELEASE=12.0-CURRENT
OSREL=12.0
OSVERSION=1200062
PYTHONBASE=/usr/local
HAVE_COMPAT_IA32_KERN=YES
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ja2-0.14.01 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.5.txz
[head-amd64-default-job-02] Installing pkg-1.10.5...
[head-amd64-default-job-02] Extracting pkg-1.10.5: .......... done
===>   ja2-0.14.01 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ja2-0.14.01
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ja2-0.14.01 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ja2-0.14.01 for building
=> SHA256 Checksum OK for ja2/v0.14.01.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ja2-0.14.01 for building
===>  Extracting for ja2-0.14.01
=> SHA256 Checksum OK for ja2/v0.14.01.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ja2-0.14.01
===>  Applying FreeBSD patches for ja2-0.14.01
===========================================================================
=======================<phase: build-depends  >============================
===>   ja2-0.14.01 depends on file: /usr/local/bin/sdl-config - not found
===>   Installing existing package /packages/All/sdl-1.2.15_10,2.txz
[head-amd64-default-job-02] Installing sdl-1.2.15_10,2...
[head-amd64-default-job-02] `-- Installing aalib-1.4.r5_11...
[head-amd64-default-job-02] |   `-- Installing indexinfo-0.3.1...
[head-amd64-default-job-02] |   `-- Extracting indexinfo-0.3.1: .... done
[head-amd64-default-job-02] `-- Extracting aalib-1.4.r5_11: .......... done
[head-amd64-default-job-02] `-- Installing libGLU-9.0.0_3...
[head-amd64-default-job-02] |   `-- Installing mesa-libs-18.0.0...
[head-amd64-default-job-02] |   | `-- Installing expat-2.2.5...
[head-amd64-default-job-02] |   | `-- Extracting expat-2.2.5: .......... done
[head-amd64-default-job-02] |   | `-- Installing libX11-1.6.5,1...
[head-amd64-default-job-02] |   |   `-- Installing kbproto-1.0.7...
[head-amd64-default-job-02] |   |   `-- Extracting kbproto-1.0.7: .......... 
done
[head-amd64-default-job-02] |   |   `-- Installing libXau-1.0.8_3...
[head-amd64-default-job-02] |   |   | `-- Installing xproto-7.0.31...
[head-amd64-default-job-02] |   |   | `-- Extracting xproto-7.0.31: .......... 
done
[head-amd64-default-job-02] |   |   `-- Extracting libXau-1.0.8_3: .......... 
done
[head-amd64-default-job-02] |   |   `-- Installing libXdmcp-1.1.2...
[head-amd64-default-job-02] |   |   `-- Extracting libXdmcp-1.1.2: ......... 
done
[head-amd64-default-job-02] |   |   `-- Installing libxcb-1.12_2...
[head-amd64-default-job-02] |   |   | `-- Installing libpthread-stubs-0.4...
[head-amd64-default-job-02] |   |   | `-- Extracting libpthread-stubs-0.4: .... 
done
[head-amd64-default-job-02] |   |   | `-- Installing libxml2-2.9.7...
[head-amd64-default-job-02] |   |   | `-- Extracting libxml2-2.9.7: .......... 
done
[head-amd64-default-job-02] |   |   `-- Extracting libxcb-1.12_2: .......... 
done
[head-amd64-default-job-02] |   | `-- Extracting libX11-1.6.5,1: .......... done
[head-amd64-default-job-02] |   | `-- Installing libXdamage-1.1.4_3...
[head-amd64-default-job-02] |   |   `-- Installing damageproto-1.2.1...
[head-amd64-default-job-02] |   |   `-- Extracting damageproto-1.2.1: .... done
[head-amd64-default-job-02] |   |   `-- Installing libXfixes-5.0.3...
[head-amd64-default-job-02] |   |   | `-- Installing fixesproto-5.0...
[head-amd64-default-job-02] |   |   | `-- Extracting fixesproto-5.0: ....... 
done
[head-amd64-default-job-02] |   |   `-- Extracting libXfixes-5.0.3: .......... 
done
[head-amd64-default-job-02] |   | `-- Extracting libXdamage-1.1.4_3: ...... done
[head-amd64-default-job-02] |   | `-- Installing libXext-1.3.3_1,1...
[head-amd64-default-job-02] |   |   `-- Installing xextproto-7.3.0...
[head-amd64-default-job-02] |   |   `-- Extracting xextproto-7.3.0: .......... 
done
[head-amd64-default-job-02] |   | `-- Extracting libXext-1.3.3_1,1: .......... 
done
[head-amd64-default-job-02] |   | `-- Installing libXxf86vm-1.1.4_1...
[head-amd64-default-job-02] |   |   `-- Installing xf86vidmodeproto-2.3.1...
[head-amd64-default-job-02] |   |   `-- Extracting xf86vidmodeproto-2.3.1: .... 
done
[head-amd64-default-job-02] |   | `-- Extracting libXxf86vm-1.1.4_1: .......... 
done
[head-amd64-default-job-02] |   | `-- Installing libdrm-2.4.89,1...
[head-amd64-default-job-02] |   |   `-- Installing libpciaccess-0.13.5...
[head-amd64-default-job-02] |   |   | `-- Installing pciids-20180406...
[head-amd64-default-job-02] |   |   | `-- Extracting pciids-20180406: ..... done
[head-amd64-default-job-02] |   |   `-- Extracting libpciaccess-0.13.5: ...... 
done
[head-amd64-default-job-02] |   | `-- Extracting libdrm-2.4.89,1: .......... 
done
[head-amd64-default-job-02] |   | `-- Installing libunwind-20170615...
[head-amd64-default-job-02] |   | `-- Extracting libunwind-20170615: .......... 
done
[head-amd64-default-job-02] |   | `-- Installing libxshmfence-1.2_2...
[head-amd64-default-job-02] |   | `-- Extracting libxshmfence-1.2_2: ......... 
done
[head-amd64-default-job-02] |   `-- Extracting mesa-libs-18.0.0: .......... done
[head-amd64-default-job-02] `-- Extracting libGLU-9.0.0_3: ...... done
[head-amd64-default-job-02] `-- Installing libXrandr-1.5.1...
[head-amd64-default-job-02] |   `-- Installing libXrender-0.9.10...
[head-amd64-default-job-02] |   | `-- Installing renderproto-0.11.1...
[head-amd64-default-job-02] |   | `-- Extracting renderproto-0.11.1: .... done
[head-amd64-default-job-02] |   `-- Extracting libXrender-0.9.10: .......... 
done
[head-amd64-default-job-02] |   `-- Installing randrproto-1.5.0...
[head-amd64-default-job-02] |   `-- Extracting randrproto-1.5.0: ....... done
[head-amd64-default-job-02] `-- Extracting libXrandr-1.5.1: .......... done
[head-amd64-default-job-02] Extracting sdl-1.2.15_10,2: .......... done
Message from aalib-1.4.r5_11:

===>   NOTICE:

The aalib port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
Message from sdl-1.2.15_10,2:

------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   ja2-0.14.01 depends on file: /usr/local/bin/sdl-config - found
===>   Returning to build of ja2-0.14.01
===>   ja2-0.14.01 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_2.txz
[head-amd64-default-job-02] Installing gmake-4.2.1_2...
[head-amd64-default-job-02] `-- Installing gettext-runtime-0.19.8.1_1...
[head-amd64-default-job-02] `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[head-amd64-default-job-02] Extracting gmake-4.2.1_2: .......... done
===>   ja2-0.14.01 depends on executable: gmake - found
===>   Returning to build of ja2-0.14.01
===========================================================================
=======================<phase: lib-depends    >============================
===>   ja2-0.14.01 depends on shared library: libSDL.so - found 
(/usr/local/lib/libSDL.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ja2-0.14.01
===========================================================================
=======================<phase: build          >============================
===>  Building for ja2-0.14.01
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/games/jaggedalliance2/work/gennady-ja2-stracciatella-5585014471a7'
===> CC _build/lib-slog/slog/slog.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing 
-DGAME_VERSION=\"v0.14.01\" -I/usr/local/include/SDL -I/usr/local/include 
-D_REENTRANT -D_THREAD_SAFE -I . -I Build -I Build/Editor -I Build/Laptop -I 
Build/Res -I Build/Strategic -I Build/Tactical -I Build/TacticalAI -I 
Build/TileEngine -I Build/Utils -I sgp -I src -I _build/lib-MicroIni/include -I 
_build/lib-boost -I _build/lib-rapidjson -I _build/lib-slog -I 
_build/lib-smacker/libsmacker -I _build/lib-utf8cpp/source -Wpointer-arith 
-Wreturn-type -Wunused-label -Wunused-variable -Wwrite-strings -DJA2 
-DMICROINI_STATIC -D WITH_UNITTESTS -I _build/lib-gtest/include -I 
_build/lib-gtest -std=gnu99 -Werror-implicit-function-declaration 
-Wimplicit-int -Wmissing-prototypes -c -MMD -o _build/lib-slog/slog/slog.o 
_build/lib-slog/slog/slog.c
===> CC _build/lib-smacker/libsmacker/smacker.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing 
-DGAME_VERSION=\"v0.14.01\" -I/usr/local/include/SDL -I/usr/local/include 
-D_REENTRANT -D_THREAD_SAFE -I . -I Build -I Build/Editor -I Build/Laptop -I 
Build/Res -I Build/Strategic -I Build/Tactical -I Build/TacticalAI -I 
Build/TileEngine -I Build/Utils -I sgp -I src -I _build/lib-MicroIni/include -I 
_build/lib-boost -I _build/lib-rapidjson -I _build/lib-slog -I 
_build/lib-smacker/libsmacker -I _build/lib-utf8cpp/source -Wpointer-arith 
-Wreturn-type -Wunused-label -Wunused-variable -Wwrite-strings -DJA2 
-DMICROINI_STATIC -D WITH_UNITTESTS -I _build/lib-gtest/include -I 
_build/lib-gtest -std=gnu99 -Werror-implicit-function-declaration 
-Wimplicit-int -Wmissing-prototypes -c -MMD -o 
_build/lib-smacker/libsmacker/smacker.o _build/lib-smacker/libsmacker/smacker.c
===> CC _build/lib-smacker/libsmacker/smk_hufftree.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing 
-DGAME_VERSION=\"v0.14.01\" -I/usr/local/include/SDL -I/usr/local/include 
-D_REENTRANT -D_THREAD_SAFE -I . -I Build -I Build/Editor -I Build/Laptop -I 
Build/Res -I Build/Strategic -I Build/Tactical -I Build/TacticalAI -I 
Build/TileEngine -I Build/Utils -I sgp -I src -I _build/lib-MicroIni/include -I 
_build/lib-boost -I _build/lib-rapidjson -I _build/lib-slog -I 
_build/lib-smacker/libsmacker -I _build/lib-utf8cpp/source -Wpointer-arith 
-Wreturn-type -Wunused-label -Wunused-variable -Wwrite-strings -DJA2 
-DMICROINI_STATIC -D WITH_UNITTESTS -I _build/lib-gtest/include -I 
_build/lib-gtest -std=gnu99 -Werror-implicit-function-declaration 
-Wimplicit-int -Wmissing-prototypes -c -MMD -o 
_build/lib-smacker/libsmacker/smk_hufftree.o 
_build/lib-smacker/libsmacker/smk_hufftree.c
===> CC _build/lib-smacker/libsmacker/smk_bitstream.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing 
-DGAME_VERSION=\"v0.14.01\" -I/usr/local/include/SDL -I/usr/local/include 
-D_REENTRANT -D_THREAD_SAFE -I . -I Build -I Build/Editor -I Build/Laptop -I 
Build/Res -I Build/Strategic -I Build/Tactical -I Build/TacticalAI -I 
Build/TileEngine -I Build/Utils -I sgp -I src -I _build/lib-MicroIni/include -I 
_build/lib-boost -I _build/lib-rapidjson -I _build/lib-slog -I 
_build/lib-smacker/libsmacker -I _build/lib-utf8cpp/source -Wpointer-arith 
-Wreturn-type -Wunused-label -Wunused-variable -Wwrite-strings -DJA2 
-DMICROINI_STATIC -D WITH_UNITTESTS -I _build/lib-gtest/include -I 
_build/lib-gtest -std=gnu99 -Werror-implicit-function-declaration 
-Wimplicit-int -Wmissing-prototypes -c -MMD -o 
_build/lib-smacker/libsmacker/smk_bitstream.o 
_build/lib-smacker/libsmacker/smk_bitstream.c
===> CXX Build/AniViewScreen.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o Build/AniViewScreen.o 
Build/AniViewScreen.cc
===> CXX Build/Credits.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o Build/Credits.o 
Build/Credits.cc
===> CXX Build/UILayout.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o Build/UILayout.o 
Build/UILayout.cc
===> CXX Build/Editor/Cursor_Modes.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o 
Build/Editor/Cursor_Modes.o Build/Editor/Cursor_Modes.cc
===> CXX Build/Editor/EditScreen.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o 
Build/Editor/EditScreen.o Build/Editor/EditScreen.cc
===> CXX Build/Editor/Edit_Sys.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o Build/Editor/Edit_Sys.o 
Build/Editor/Edit_Sys.cc
===> CXX Build/Editor/EditorBuildings.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o 
Build/Editor/EditorBuildings.o Build/Editor/EditorBuildings.cc
===> CXX Build/Editor/EditorItems.cc
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing  -O2 -pipe  
-fstack-protector -fno-strict-aliasing -DGAME_VERSION=\"v0.14.01\" 
-I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -I . 
-I Build -I Build/Editor -I Build/Laptop -I Build/Res -I Build/Strategic -I 
Build/Tactical -I Build/TacticalAI -I Build/TileEngine -I Build/Utils -I sgp -I 
src -I _build/lib-MicroIni/include -I _build/lib-boost -I _build/lib-rapidjson 
-I _build/lib-slog -I _build/lib-smacker/libsmacker -I 
_build/lib-utf8cpp/source -Wpointer-arith -Wreturn-type -Wunused-label 
-Wunused-variable -Wwrite-strings -DJA2 -DMICROINI_STATIC -D WITH_UNITTESTS -I 
_build/lib-gtest/include -I _build/lib-gtest -c -MMD -o 
Build/Editor/EditorItems.o Build/Editor/EditorItems.cc
Build/Editor/EditorItems.cc:295:27: error: non-constant-expression cannot be 
narrowed from type 'int' to 'INT16' (aka 'short') in initializer list 
[-Wc++11-narrowing]
                SGPBox const r = { 100, EDITOR_TASKBAR_POS_Y, 60, 80 };
                                        ^~~~~~~~~~~~~~~~~~~~
Build/UILayout.h:34:41: note: expanded from macro 'EDITOR_TASKBAR_POS_Y'
#define EDITOR_TASKBAR_POS_Y            (SCREEN_HEIGHT - EDITOR_TASKBAR_HEIGHT)
                                        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Build/Editor/EditorItems.cc:295:27: note: insert an explicit cast to silence 
this issue
                SGPBox const r = { 100, EDITOR_TASKBAR_POS_Y, 60, 80 };
                                        ^~~~~~~~~~~~~~~~~~~~
                                        static_cast<INT16>( )
Build/UILayout.h:34:41: note: expanded from macro 'EDITOR_TASKBAR_POS_Y'
#define EDITOR_TASKBAR_POS_Y            (SCREEN_HEIGHT - EDITOR_TASKBAR_HEIGHT)
                                        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Build/Editor/EditorItems.cc:514:21: error: non-constant-expression cannot be 
narrowed from type 'int' to 'INT16' (aka 'short') in initializer list 
[-Wc++11-narrowing]
        SGPBox const r = { 60 * scroll_idx, 0, 360, 80 };
                           ^~~~~~~~~~~~~~~
Build/Editor/EditorItems.cc:514:21: note: insert an explicit cast to silence 
this issue
        SGPBox const r = { 60 * scroll_idx, 0, 360, 80 };
                           ^~~~~~~~~~~~~~~
                           static_cast<INT16>( )
2 errors generated.
gmake[1]: *** [Makefile:599: Build/Editor/EditorItems.o] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/games/jaggedalliance2/work/gennady-ja2-stracciatella-5585014471a7'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/jaggedalliance2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to