You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     p...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2018Q4/security/p5-Crypt-OpenSSL-CA/Makefile 
449893 2017-09-15 08:58:46Z mat $
Log URL:        
http://beefy14.nyi.freebsd.org/data/120mips-quarterly/486733/logs/p5-Crypt-OpenSSL-CA-0.24_2.log
Build URL:      
http://beefy14.nyi.freebsd.org/build.html?mastername=120mips-quarterly&build=486733
Log:

=>> Building security/p5-Crypt-OpenSSL-CA
build started at Fri Dec  7 09:33:54 UTC 2018
port directory: /usr/ports/security/p5-Crypt-OpenSSL-CA
package name: p5-Crypt-OpenSSL-CA-0.24_2
building for: FreeBSD 120mips-quarterly-job-01 12.0-RC3 FreeBSD 12.0-RC3 
1200086 mips
maintained by: p...@freebsd.org
Makefile ident:      $FreeBSD: 
branches/2018Q4/security/p5-Crypt-OpenSSL-CA/Makefile 449893 2017-09-15 
08:58:46Z mat $
Poudriere version: 3.2.8
Host OSVERSION: 1300002
Jail OSVERSION: 1200086
Job Id: 01

---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1200086
UNAME_v=FreeBSD 12.0-RC3 1200086
UNAME_r=12.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8
MASTERMNT=/usr/local/poudriere/data/.m/120mips-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/120mips-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=120mips-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/120mips-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
p...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--openssl-cflags=-L/usr/include --openssl-ldflags="-I/usr/lib " --install_path 
lib="/usr/local/lib/perl5/site_perl"  --install_path 
arch="/usr/local/lib/perl5/site_perl/mach/5.26"  --install_path 
script="/usr/local/bin"  --install_path bin="/usr/local/bin"  --install_path 
libdoc="/usr/local/lib/perl5/site_perl/man/man3"  --install_path 
bindoc="/usr/local/lib/perl5/site_perl/man/man1" --destdir 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/stage 
--perl="/usr/local/bin/perl" --create_packlist 1 CC="/nxb-bin/usr/bin/cc" 
CCFLAGS="-O2 -pipe -G0 -EB -mabi=32 -msoft-float  -fno-strict-aliasing " 
LD="/nxb-bin/usr/bin/cc" PREFIX="/usr/local"  INSTALLPRIVLIB="/usr/local/lib" 
INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl  
PERL_USE_UNSAFE_INC=1 
XDG_DATA_HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work  
HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh PERL_EXTUTILS_AUTOINSTALL="--skipdeps" 
PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
PERL_USE_UNSAFE_INC=1 OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl 
OPENSSLINC=/usr/include OPENSSLLIB=/usr/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work  
HOME=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe -G0 -EB -mabi=32 -msoft-float  -fno-strict-aliasing "  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -EB -mabi=32  " LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 -EB -mabi=32 -msoft-float 
-fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  
-s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  
-m 555"  BSD_INSTALL_DATA=
 "install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=12.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
PERL_VERSION=5.26.2  PERL_VER=5.26  PERL5_MAN1=lib/perl5/site_perl/man/man1  
PERL5_MAN3=lib/perl5/site_perl/man/man3  SITE_PERL=lib/perl5/site_perl  
SITE_ARCH=lib/perl5/site_perl/mach/5.26 DOCSDIR="share/doc/Crypt-OpenSSL-CA"  
EXAMPLESDIR="share/examples/Crypt-OpenSSL-CA"  DATADIR="share/Crypt-OpenSSL-CA" 
 WWWDIR="www/Crypt-OpenSSL-CA"  ETCDIR="etc/Crypt-OpenSSL-CA"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  
DATADIR=/usr/local/share/Crypt-OpenSSL-CA 
DOCSDIR=/usr/local/share/doc/Crypt-OpenSSL-CA 
EXAMPLESDIR=/usr/local/share/examples/Crypt-OpenSSL-CA  
WWWDIR=/usr/local/www/Crypt-OpenSSL-CA ETCDIR=/usr/local/etc/Crypt-OpenSSL-CA
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=mips
MACHINE_ARCH=mips
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2

# stable/10 includes src.conf too late but make.conf is in sys.mk
.if ${.CURDIR:M/poudriere/jails/10*/usr/src/usr.bin/xlint*}
# Disable build of llib now that head no longer has lint(1)
LINT=   true
.endif
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 
2007 Free Software Foundation, Inc. This is free software; see the source for 
copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=Using built-in specs. Target: mips-undermydesk-freebsd 
Configured with: FreeBSD/mips system compiler Thread model: posix gcc version 
4.2.1 20070831 patched [FreeBSD] "/usr/bin/ld" "--eh-frame-hdr" "-EB" "-EB" 
"-melf32btsmip_fbsd" "--enable-new-dtags" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "/usr/lib/crt1.o" "/usr/lib/crti.o" 
"/usr/lib/crtbegin.o" "-L/usr/lib" "-L/usr/lib" "/dev/null" "-lstdc++" "-lm" 
"-lgcc_s" "-lgcc" "-lc" "-lgcc_s" "-lgcc" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=cc1: error: unrecognized command line option 
"-std=c11"
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=cc1: error: unrecognized command line option 
"-std=gnu11"
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=cc1plus: error: unrecognized command line option 
"-std=c++0x"
CC_OUTPUT_9d218390_f00456e5=cc1plus: error: unrecognized command line option 
"-std=c++11"
CC_OUTPUT_9d218390_65ad290d=cc1plus: error: unrecognized command line option 
"-std=c++14"
CC_OUTPUT_9d218390_f2776b26=cc1plus: error: unrecognized command line option 
"-std=c++17"
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=cc1plus: error: unrecognized command line option 
"-std=gnu++11"
CC_OUTPUT_9d218390_160933ec=cc1plus: error: unrecognized command line option 
"-std=gnu++14"
CC_OUTPUT_9d218390_fb62803b=cc1plus: error: unrecognized command line option 
"-std=gnu++17"
_OBJC_CCVERSION_9d218390=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright 
(C) 2007 Free Software Foundation, Inc. This is free software; see the source 
for copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_OBJC_ALTCCVERSION_9d218390=none
ARCH=mips
OPSYS=FreeBSD
_OSRELEASE=12.0-RC3
OSREL=12.0
OSVERSION=1200086
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  131072
stack size              (kbytes, -s)  8192
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License ART10 GPLv1+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.10.5_5.txz
[120mips-quarterly-job-01] Installing pkg-1.10.5_5...
[120mips-quarterly-job-01] Extracting pkg-1.10.5_5: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ART10 GPLv1+ accepted by the user
===> Fetching all distfiles required by p5-Crypt-OpenSSL-CA-0.24_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ART10 GPLv1+ accepted by the user
===> Fetching all distfiles required by p5-Crypt-OpenSSL-CA-0.24_2 for building
=> SHA256 Checksum OK for Crypt-OpenSSL-CA-0.24.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ART10 GPLv1+ accepted by the user
===> Fetching all distfiles required by p5-Crypt-OpenSSL-CA-0.24_2 for building
===>  Extracting for p5-Crypt-OpenSSL-CA-0.24_2
=> SHA256 Checksum OK for Crypt-OpenSSL-CA-0.24.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Crypt-OpenSSL-CA-0.24_2
===>  Applying FreeBSD patches for p5-Crypt-OpenSSL-CA-0.24_2
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Convert-ASN1>=0.02 - 
not found
===>   Installing existing package /packages/All/p5-Convert-ASN1-0.27_2.txz
[120mips-quarterly-job-01] Installing p5-Convert-ASN1-0.27_2...
[120mips-quarterly-job-01] `-- Installing perl5-5.26.2...
[120mips-quarterly-job-01] `-- Extracting perl5-5.26.2: .......... done
[120mips-quarterly-job-01] Extracting p5-Convert-ASN1-0.27_2: .......... done
Message from perl5-5.26.2:

The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Convert-ASN1>=0.02 - 
found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Devel-Leak>=0 - not 
found
===>   Installing existing package /packages/All/p5-Devel-Leak-0.03_1.txz
[120mips-quarterly-job-01] Installing p5-Devel-Leak-0.03_1...
[120mips-quarterly-job-01] Extracting p5-Devel-Leak-0.03_1: .... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Devel-Leak>=0 - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-File-Slurp>=0 - not 
found
===>   Installing existing package /packages/All/p5-File-Slurp-9999.19_1.txz
[120mips-quarterly-job-01] Installing p5-File-Slurp-9999.19_1...
[120mips-quarterly-job-01] Extracting p5-File-Slurp-9999.19_1: ....... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-File-Slurp>=0 - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-IPC-Run>=0 - not found
===>   Installing existing package /packages/All/p5-IPC-Run-0.99.txz
[120mips-quarterly-job-01] Installing p5-IPC-Run-0.99...
[120mips-quarterly-job-01] `-- Installing p5-IO-Tty-1.12_2...
[120mips-quarterly-job-01] `-- Extracting p5-IO-Tty-1.12_2: .......... done
[120mips-quarterly-job-01] Extracting p5-IPC-Run-0.99: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-IPC-Run>=0 - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Inline>=0.40 - not 
found
===>   Installing existing package /packages/All/p5-Inline-0.80.txz
[120mips-quarterly-job-01] Installing p5-Inline-0.80...
[120mips-quarterly-job-01] `-- Installing p5-Parse-RecDescent-1.967.009_2...
[120mips-quarterly-job-01] `-- Extracting p5-Parse-RecDescent-1.967.009_2: 
.......... done
[120mips-quarterly-job-01] Extracting p5-Inline-0.80: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Inline>=0.40 - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Inline-C>=0 - not found
===>   Installing existing package /packages/All/p5-Inline-C-0.78.txz
[120mips-quarterly-job-01] Installing p5-Inline-C-0.78...
[120mips-quarterly-job-01] `-- Installing p5-Pegex-0.66...
[120mips-quarterly-job-01] |   `-- Installing p5-JSON-XS-3.04...
[120mips-quarterly-job-01] |   | `-- Installing p5-Types-Serialiser-1.0_1...
[120mips-quarterly-job-01] |   |   `-- Installing p5-common-sense-3.74...
[120mips-quarterly-job-01] |   |   `-- Extracting p5-common-sense-3.74: 
........ done
[120mips-quarterly-job-01] |   | `-- Extracting p5-Types-Serialiser-1.0_1: 
......... done
[120mips-quarterly-job-01] |   `-- Extracting p5-JSON-XS-3.04: .......... done
[120mips-quarterly-job-01] |   `-- Installing p5-YAML-LibYAML-0.72...
[120mips-quarterly-job-01] |   `-- Extracting p5-YAML-LibYAML-0.72: .......... 
done
[120mips-quarterly-job-01] `-- Extracting p5-Pegex-0.66: .......... done
[120mips-quarterly-job-01] Extracting p5-Inline-C-0.78: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Inline-C>=0 - found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Net-SSLeay>=1.25 - not 
found
===>   Installing existing package /packages/All/p5-Net-SSLeay-1.85.txz
[120mips-quarterly-job-01] Installing p5-Net-SSLeay-1.85...
[120mips-quarterly-job-01] Extracting p5-Net-SSLeay-1.85: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Net-SSLeay>=1.25 - 
found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Module-Build>=0.4206 - 
not found
===>   Installing existing package /packages/All/p5-Module-Build-0.4224.txz
[120mips-quarterly-job-01] Installing p5-Module-Build-0.4224...
[120mips-quarterly-job-01] Extracting p5-Module-Build-0.4224: .......... done
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: p5-Module-Build>=0.4206 - 
found
===>   Returning to build of p5-Crypt-OpenSSL-CA-0.24_2
===>   p5-Crypt-OpenSSL-CA-0.24_2 depends on package: perl5>=5.26<5.27 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Crypt-OpenSSL-CA-0.24_2
Checking prerequisites...
  build_requires:
    !  Devel::Mallinfo is not installed
    !  Test::Group is not installed
    !  Test::Taint is not installed

ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation

Run 'Build installdeps' to install missing prerequisites.


I need some of the above Perl dependencies (most notably, Inline::C)
so as to check that the OpenSSL development kit works.  Therefore,

   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   !!  Please re-run ./Build.PL  !!
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

once all the Perl dependencies have been satisfied.

Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Crypt-OpenSSL-CA' version '0.24'
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-Crypt-OpenSSL-CA-0.24_2

Checking OpenSSL version number...

Found 0x1010101fd.  Good.

/usr/local/bin/perl5.26.2 -I 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib 
-e BEGIN { $Crypt::OpenSSL::CA::VERSION = '0.24' ; } use 
Crypt::OpenSSL::CA::Inline::C; use Inline qw(_INSTALL_); use 
Crypt::OpenSSL::CA; 0.24 blib/arch 
Unrecognized argument in LIBS ignored: '-I/usr/lib'
Generating a Unix-style Makefile
Writing Makefile for Crypt::OpenSSL::CA::PrivateKey
Writing MYMETA.yml and MYMETA.json
Running Mkbootstrap for PrivateKey ()
chmod 644 "PrivateKey.bs"
"/usr/local/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- PrivateKey.bs 
blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.bs 644
"/usr/local/bin/perl" "/usr/local/lib/perl5/5.26/ExtUtils/xsubpp"  -typemap 
"/usr/local/lib/perl5/5.26/ExtUtils/typemap"  PrivateKey.xs > PrivateKey.xsc
mv PrivateKey.xsc PrivateKey.c
/usr/bin/cc -c  
-I"/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24" 
-L/usr/include  -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing 
-pipe -I/usr/local/include -D_FORTIFY_SOURCE=2 -g -O2    -DVERSION=\"0.24\"  
-DXS_VERSION=\"0.24\" -DPIC -fPIC "-I/usr/local/lib/perl5/5.26/mach/CORE"   
PrivateKey.c
rm -f blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.so
LD_RUN_PATH="/usr/lib" /usr/bin/cc  -shared  
-L/usr/local/lib/perl5/5.26/mach/CORE -lperl -L/usr/local/lib PrivateKey.o  -o 
blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.so    -lcrypto -lssl    
chmod 755 blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.so
"/usr/local/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- PrivateKey.bs 
blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.bs 644
Files found in blib/arch: installing files in blib/lib into architecture 
dependent library tree
Installing 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/blib/arch/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.so
Unrecognized argument in LIBS ignored: '-I/usr/lib'
Generating a Unix-style Makefile
Writing Makefile for Crypt::OpenSSL::CA::X509_CRL
Writing MYMETA.yml and MYMETA.json
Running Mkbootstrap for X509_CRL ()
chmod 644 "X509_CRL.bs"
"/usr/local/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- X509_CRL.bs 
blib/arch/auto/Crypt/OpenSSL/CA/X509_CRL/X509_CRL.bs 644
"/usr/local/bin/perl" "/usr/local/lib/perl5/5.26/ExtUtils/xsubpp"  -typemap 
"/usr/local/lib/perl5/5.26/ExtUtils/typemap"  X509_CRL.xs > X509_CRL.xsc
mv X509_CRL.xsc X509_CRL.c
/usr/bin/cc -c  
-I"/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24" 
-L/usr/include  -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing 
-pipe -I/usr/local/include -D_FORTIFY_SOURCE=2 -g -O2    -DVERSION=\"0.24\"  
-DXS_VERSION=\"0.24\" -DPIC -fPIC "-I/usr/local/lib/perl5/5.26/mach/CORE"   
X509_CRL.c
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:
 In function 'get_lastUpdate':
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2226:
 warning: 'X509_CRL_get_lastUpdate' is deprecated (declared at 
/usr/include/openssl/x509.h:727)
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:
 In function 'get_nextUpdate':
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2255:
 warning: 'X509_CRL_get_nextUpdate' is deprecated (declared at 
/usr/include/openssl/x509.h:728)
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:
 In function 'get_entryNumbers':
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2311:
 error: dereferencing pointer to incomplete type
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2319:
 error: dereferencing pointer to incomplete type
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:
 In function 'get_entry_revoke_date':
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2384:
 error: dereferencing pointer to incomplete type
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:
 In function 'get_entry_serial':
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm:2419:
 error: dereferencing pointer to incomplete type
*** Error code 1

Stop.
make[1]: stopped in 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/_Inline/build/Crypt/OpenSSL/CA/X509_CRL

A problem was encountered while attempting to compile and install your Inline
C code. The command that failed was:
  "make" with error code 1

The build directory was:
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/_Inline/build/Crypt/OpenSSL/CA/X509_CRL

To debug the problem, cd to the build directory, and inspect the output files.

 at (eval 34) line 20.
        ...propagated at /usr/local/lib/perl5/site_perl/Inline/C.pm line 869.
BEGIN failed--compilation aborted at (eval 34) line 20.
BEGIN failed--compilation aborted at 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/lib/Crypt/OpenSSL/CA.pm
 line 3053.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
Command exited with status 25 at 
/wrkdirs/usr/ports/security/p5-Crypt-OpenSSL-CA/work/Crypt-OpenSSL-CA-0.24/_build/lib/MyModuleBuilder.pm
 line 228.
*** Error code 2

Stop.
make: stopped in /usr/ports/security/p5-Crypt-OpenSSL-CA
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to