I tried updating Samba to 3.4 (from 3.3) as libsmbclient uses it and 
that pulls in talloc which conflicts with 3.3..

Unfortunately when I tried it, it hung when I tried to use the ldap 
passdb backend. I could not really get any useful debugging out of it

The stack trace is junk (even after enabling max debug) and running 
sudo /usr/local/sbin/smbd -d 10 -F -S

Showed stuff but nothing related to LDAP (except mentioning the line in 
the config) and it still hung after saying it was going to daemonise 

It hung not using any CPU but it hadn't yet opened any TCP listen 
sockets - however it did have a socket to the LDAP server open.

Does anyone actually use this combination on FreeBSD?

I have had various annoying issues with LDAP (eg slapd crashing when 
it's not shut down cleanly, various frustrations getting it setup etc) 
but I haven't come across this bug before.

Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply via email to