Hello,

As exposed on some postgis bugs. I propose an infrastructure framework for this ports.


PostGis is not compatible with all versions of PostGreSQL (https://trac.osgeo.org/postgis/wiki/UsersWikiPostgreSQLPostGIS). So postgis.mk can check if a version of postgis is already installed and compatible, and check if postgresql is compatible too.

What I've done:

- Create the  Uses file (Mk/Uses/postgis.mk)

- Add a default version of postgis (Mk/bsd.default-versions.mk)

- Modify all postgis Makefile. There may a problem with postgis21 which require a PGSQL version between 9.1 and 9.4 (Uses= pgsql:9.1+ pgsql:9.4- is it correct? Can we have bounded versions?)

- Modify all dependent ports (Qgis, Pgrouting)

All files can be downloaded from http://download.tuxfamily.org/bartcoding/postgis.tar.gz. You have several patch. The file all.diff contain... all patch.


Can you help me to test this framework?

Thank you in advance.

Regards,

Loïc BARTOLETTI

PS: I can't send this mail to harrison.grundy at astrodoggroup.com maintainer of PostGis21


_______________________________________________
freebsd-ports@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "freebsd-ports-unsubscr...@freebsd.org"

Reply via email to