On 2016-09-21 15:26, Mark Felder wrote:
On Wed, Sep 21, 2016, at 12:52, Naram Qashat wrote:
I can't seem to get the phantomjs port to build for me under FreeBSD
10.3. I have lang/gcc installed (so I have gcc48 and g++48) and clang is the base compiler. It seems that it is trying to use g++48, but there is
no freebsd-g++48 mkspec and it fails to even start building.

I've even tried to set CC and CXX manually but that doesn't help because
of the mkspec issue. It seems to always try using gcc48 and g++48
regardless of what CC and CXX are set to.

Do you have more details about how you're trying to build it? It builds
with clang, not gcc. It should not be attempting to use gcc at all.

I'm building using portupgrade, but the problem happens even if I build directly with make from /usr/ports/lang/phantomjs too. I use portconf, but even with all the options commented out in there, it still doesn't build.

Here is the cluster build log for 10.1 amd64 (10.1 is build target for
all packages used for 10.1, 10.2, and 10.3)


Looking at that build log, I see a difference when it checks for g++ and g++48. On my system, since I have g++ and g++48 from lang/gcc, it sets PLATFORM to freebsd-g++ when it finds g++ and then to freebsd-g++48 when it finds g++48, so XPLATFORM gets set to freebsd-g++48 instead of freebsd-clang. I assume that uninstalling lang/gcc would make it build, but this seems more like a problem with how phantomjs is checking for compilers (and then not having the required mkspec).
freebsd-ports@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-ports-unsubscr...@freebsd.org"

Reply via email to