On Mon, 2018-02-19 at 07:50 +0000, Marcin Cieslak wrote:
> On Mon, 19 Feb 2018, Karli Sjöberg wrote:
> 
> > 
> > 
> > Den 18 feb. 2018 23:49 skrev Marcin Cieslak <sa...@saper.info>:
> >       On Sat, 17 Feb 2018, Karli Sjöberg via freebsd-ports wrote:
> >       CONFIG
> >       > /usr/local/lib/ruby/gems/2.4/gems/foreman_maintain-
> > 0.1.3/bin/passenger-recycler:8: warning: previous definition of
> > CONFIG
> >        was here
> >       >
> > /usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.
> > rb:135:in `require': cannot load such file --
> >       /phusion_passenger/utils/tmpio (LoadError)
> >       >         from
> > /usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.
> > rb:135:in `rescue in require'
> >       >         from
> > /usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.
> > rb:39:in `require'
> >       >         from /usr/local/lib/ruby/gems/2.4/gems/passenger-
> > 5.2.0/src/ruby_supportlib/phusion_passenger.rb:240:in
> >       `require_passenger_lib'
> >       >         from /usr/local/lib/ruby/gems/2.4/gems/passenger-
> > 5.2.0/src/ruby_supportlib/phusion_passenger/platform_info.rb:26:in
> >       `'
> > 
> >       Where did you get passenger 5.2.0?
> > 
> >       Can you try to install passenger 5.1.12 from ports and see if
> > it works better?
> > 
> > 
> > Right, yeah, no, I started with 5.1.12 from ports and when it
> > didn't work, I installed a newer version with 'gem'. I can
> > deinstall it
> > again if you want to see the backtrace?
> 
> Would be good, please. 

irb(main):001:0> require 'phusion_passenger'
=> true
irb(main):002:0> PhusionPassenger.require_passenger_lib 'utils/tmpio'
LoadError: cannot load such file -- /phusion_passenger/utils/tmpio
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:135:in 
`require'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:135:in 
`rescue in require'
        from 
/usr/local/lib/ruby/site_ruby/2.4/rubygems/core_ext/kernel_require.rb:39:in 
`require'
        from 
/usr/local/lib/ruby/gems/2.4/gems/passenger-5.1.12/src/ruby_supportlib/phusion_passenger.rb:240:in
 `require_passenger_lib'
        from (irb):2
        from /usr/local/bin/irb:11:in `<main>'
irb(main):003:0> require 'phusion_passenger/utils/tmpio'
=> true

> I wonder how many passenger dependencies got installed via rubygems -
> would be good to
> have them restored, too. 

None, that I could see.

> What is the tool you are trying to deploy? foreman_maintain?

Exactly!

/K

> 
> Marcin

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to