On Tue, Apr 10, 2018 at 07:59:10PM +0000, Udit agarwal wrote:
> Hi,
> I am trying to make uboot for beaglebone black using
> sysutils/u-boot-beaglebone port package, but getting the following error.
> How to resolve this? I tried with FORCE_PKG_REGISTER also, but no success.
> 
> root@rtemsbuild1:/usr/ports/sysutils/u-boot-beaglebone # make install
> ===>   u-boot-beaglebone-2018.03 depends on executable: gsed - not found
> ===>   gsed-4.2.2_1 depends on executable: makeinfo - not found
> ===>   texinfo-6.5,1 depends on executable: help2man - not found
> ===>   help2man-1.47.6 depends on package: p5-Locale-gettext>=0 - not found
> ===>   p5-Locale-gettext-1.07 depends on executable: msgfmt - not found
> ===>   gettext-tools-0.19.8.1 depends on package: libiconv>=1.14_11 - not
> found

It looks for libiconv >= 1.14_11

> ===>  Installing for libiconv-1.14_11
> ===>  Checking if libiconv already installed
> ===>   An older version of libiconv is already installed (libiconv-1.14_10)

You have libiconv 1.14_10.

>       You may wish to ``make deinstall'' and install this port again
>       by ``make reinstall'' to upgrade it properly.
>       If you really wish to overwrite the old port of libiconv
>       without deleting it first, set the variable "FORCE_PKG_REGISTER"
>       in your environment or the "make install" command line.
> *** Error code 1
> 
> Stop.
> make[11]: stopped in /usr/ports/converters/libiconv
> *** Error code 1

You need to update libiconv.

-- 
Mathieu Arnold

Attachment: signature.asc
Description: PGP signature

Reply via email to