I have python=3.6 in my DEFAULT_VERSIONS, but both 2.7 and 3.6 are installed.

While trying to build libreoffice, the build attempted to use 2.7 and I kept getting the compiler errors like this:


   pyuno_util.cxx:43:18: error: no matching function for call to
   'PyUnicodeUCS2_FromUnicode'

until I changed the USES line in editors/libreoffice/Makefile from simply "python" to "python:3".

I don't think, that should be necessary -- simply having "python" there should've picked up my desired default version, right? Not sure, if this is the problem of libreoffice or python... Yours,

   -mi

_______________________________________________
freebsd-python@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-python
To unsubscribe, send any mail to "freebsd-python-unsubscr...@freebsd.org"

Reply via email to