I have a 6.1-prerelease system, originally a 6-release. I had installed
KDE and a few things from packages while installing the OS (a clean
install) but most everything has worked.

Recently, I've tried to build python IDEs from ports and they all fail.
Boa-constructor yields the following:

importing wxPython
Traceback (most recent call last):
  File "/usr/local/bin/boa.py", line 225, in ?
    import wx
line 42, in ?
    from wx._core import *
line 4, in ?
    import _core_
ImportError: /usr/X11R6/lib/libwx_base-2.6.so.0: Undefined symbol

SPE shows pretty much the same error.

WHen I try to install Eric, I get:
===>  Installing for eric-3.8.1
===>   eric-3.8.1 depends on file: /usr/local/bin/python - found
===>   Generating temporary packing list
===>  Checking if devel/eric already installed
(cd /usr/ports/devel/eric/work/eric-3.8.1 && /usr/local/bin/python
install.py -b /usr/local/bin/  -d /usr/local/lib/python2.4/site-packages )
Sorry, please install PyQt.
Error: /usr/X11R6/lib/libqt-mt.so.3: Undefined symbol "pthread_cleanup_pop"
*** Error code 1

Stop in /usr/ports/devel/eric.

(Yes, PyQt is installed).

I got these problems before I cvsupped, but rebuilding World did not help.
I then used portupgrade to rebuild ALL the ports (which took a while).
Still hasn't fixed anything.

Could one of you geniuses tell me, a mere mortal, what the heck I'm doing


PS This is a re-post with different title and more detail. Original
thread, which didn't see much action, is here:

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to