I am having some strange problems with detection of my ata hard drive, first here is 
my system config.

Asus A7V8X, AMD 2000 512mb DDR400 ram, Geforce4 Ti4200 video, Adaptec 29160, Seagate 
18gig LVD, 
WD31600 HDD on primary, Lite-on cd-rw secondary master, Memorex cd-rom secondary slave.

Sometimes Freebsd cannot detect the IDE drive unless i fiddle with bios settings, I 
have been unable to determine 
the bios setting causing this since it seems to be different every time i change 
something. The error 
i get during boot up is below.

ad0: hard error reading fsbn 3173121 of 0-3 (ad0 bn 3173121; cn 3147 tn 15 sn 0)
 trying PIO mode
ad0: hard error reading fsbn 3173121 of 0-3 (ad0 bn 3173121; cn 3147 tn 15 sn 0)
 status=59 error=04

4.7-stable dec 19th.

Play with bios settings and sometimes it will detect correctly as shown below but not 

I tried various combinations of bios settings with unpredictable results such as
reset all to defaults and it detected ok, changed boot virus detection to no and it 
still detected ok, 
changed 4th boot device from int18 to scsi/ata100 boot and it detected fine, changed 
full screen logo to disabled and it wouldnt detect the ata drive, changed everything 
to defaults and it still wont detect the ata drive. disabled the ata 100 raid and set 
dram to ddr400
and it detected again.  so its not consistant if you know what I mean.

it works good at WDMA but dont work at PIO mode. this is an older drive that is on
an 80 pin cable with a 80 pin pullout type removeable drive.

I been  using Freebsd since 2.2.2 release 

also tried setting hw.ata.ata_dma=\"YES\" in /boot/loader.conf but it seemed to ignore 

Anyone have a clue?

CPU: AMD Athlon(TM) XP 2000+ (1666.74-MHz 686-class CPU)
  Origin = \"AuthenticAMD\"  Id = 0x662  Stepping = 2
  AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory  = 536854528 (524272K bytes)
avail memory = 515436544 (503356K bytes)
Preloaded elf kernel \"kernel\" at 0xc06b8000.
Preloaded elf module \"linux.ko\" at 0xc06b809c.
Preloaded elf module \"nvidia.ko\" at 0xc06b813c.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 12 entries at 0xc00f1cd0
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
pcib1: <PCI to PCI bridge (vendor=1106 device=b168)> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
nvidia0: <GeForce4 Ti 4200> mem 
0xe7800000-0xe787ffff,0xe8000000-0xefffffff,0xe6000000-0xe6ffffff irq 11 at device 0.0 
on pci1
pci0: <unknown card> (vendor=0x1106, dev=0x3044) at 7.0 irq 5
pci0: <unknown card> (vendor=0x105a, dev=0x3376) at 8.0 irq 5
pci0: <unknown card> (vendor=0x14e4, dev=0x4401) at 9.0 irq 9
ahc0: <Adaptec 29160 Ultra160 SCSI adapter> port 0xb400-0xb4ff mem 
0xe3800000-0xe3800fff irq 11 at device 13.0 on pci0
aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
sis0: <NatSemi DP83815 10/100BaseTX> port 0xb000-0xb0ff mem 0xe3000000-0xe3000fff irq 
5 at device 14.0 on pci0
sis0: Ethernet address: 00:09:5b:0b:5e:17
miibus0: <MII bus> on sis0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
uhci0: <VIA 83C572 USB controller> port 0xa800-0xa81f irq 9 at device 16.0 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xa400-0xa41f irq 9 at device 16.1 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0xa000-0xa01f irq 9 at device 16.2 on pci0
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
pci0: <USB controller> at 16.3 irq 9
isab0: <PCI to ISA bridge (vendor=1106 device=3177)> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8235 ATA133 controller> port 0x9800-0x980f at device 17.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pcm0: <VIA VT8235> port 0xe000-0xe0ff irq 9 at device 17.5 on pci0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5\" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
IP packet filtering initialized, divert enabled, rule-based forwarding enabled, 
default to deny, unlimited logging
ad0: 1549MB <WDC AC31600H> [3148/16/63] at ata0-master WDMA2
acd0: CD-RW <LITE-ON LTR-40125S> at ata1-master PIO4
acd1: CDROM <CD-ROM 36X/AKU> at ata1-slave PIO4
Waiting 15 seconds for SCSI devices to settle
Mounting root from ufs:/dev/da0s1a
da0 at ahc0 bus 0 target 0 lun 0
da0: <SEAGATE ST318451LW 0002> Fixed Direct Access SCSI-3 device
da0: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged Queueing Enabled
da0: 17501MB (35843671 512 byte sectors: 255H 63S/T 2231C)
fire_saver: the console does not support M_VGA_CG320
module_register_init: MOD_LOAD (fire_saver, c238e6c0, 0) error 19
nvidia: rebuild nvidia.ko for FreeBSD AGPGART support.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to