I run a FreeBSD 6.0 at home in my closet.
Yesterday, while I was linking IRCd services with a friend of mine, my router
completely stopped routing any packets between the internal nic (sis0) and
the external nic (rl0).
The only thing that I can think of, whoich could have caused this, is that I
ran ettercap on the server to diagnose why our servers wouldnt link. I did NOT
run any ARP poisoning or DNS spoofing attacks on myself.
But I didnt notice if the routing stopped at that point, or later, because I
could always connect to my server, and the server could always connect to the
internet. The situation is still the same.

I have tried to do
- "ipf -Fa -f /etc/ipf.rules; ipnat -FC -f /etc/ipnat.rules" - Didnt help
- "cd /etc/rc.d; ./ipfilter restart; ./ipnat restart" - Didnt help
- Launch ettercap again and exit "cleanly" after telling it to stop sniffing.
A tcpdump reveals that, indeed, no packets at all make it from sis0 to rl0.
So my conclusion is that ipnat "forgot" how to route between the two

Could anyone please give some pointers?

Attachment: ifconfig
Description: Binary data

Attachment: ipf.rules
Description: Binary data

Attachment: ipnat.rules
Description: Binary data

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to