I've been trying to get Macromedia Flash 6 (linux-flashplayer6) to work with 
native firefox (1.5) on FreeBSD 6.0 and running into some annoying problems.

I know I needed linuxpluginwrapper to get this to work and so installed it 
along with the linux flash plugin port. I tried several times, reviewed the 
port build notes, looked for readmes, and searched some with Google. I found 
several detailed installation instructions but none of them worked for me.

In order to get it to work, I copied flashplayer.xpt and libflashplayer.so 
from the linux-flashplayer6 installation directory into the browser_plugins 
directory. I took this from instructions for getting an older flashplayer5 to 

This at least got me to an error message (about not being able to locate 
libpthreads.so. That is one of the things that linuxpluginwrapper is supposed 
to take care of.

After several more attempts at trying to resolve this, I resorted to a brute 
force method. I copied the flash6.so library that came with 
linuxpluginwrapper to the browser_plugins directory as libpthreads.so.

This is a very bad solution but I got flash working.

So, my question is how do I get this to work properly? For any who might be 
able to help, here is some relevant info:


messy file copies:
flashplayer.xpt -> ../linux-flashplugin6/flashplayer.xpt
libdl.so.2 -> /usr/local/lib/pluginwrapper/flash6.so
libflashplayer.so -> ../linux-flashplugin6/libflashplayer.so
libpthread.so.0 -> /usr/local/lib/pluginwrapper/flash6.so

So, how do I get this to work without the messy file copy?

Ean Kingston, BSc, CISSP, ARO
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to