Oliver Iberien wrote:
About 30 seconds after I finally sent this, I found the answer. It's always a matter of phrasing the Google search correctly:

$ xhost +local:local
non-network local connections being added to access control list
$ su
Password:
bsd# /usr/local/openoffice.org-2.0.2/program/spadmin
I18N: Operating system doesn't support locale "en_US"
bsd# ... and it worked. xhosts refers to networks not usernames. You run it as a normal user, then switch to su, then execute the command. I found the answer here:

http://lists.suse.com/archive/suse-xfree86/2004-Feb/0028.html

Sounds like a really insecure thing for a sysadmin to do, though. I'm just the only user of a home machine. Sorry for using up list space, but perhaps this might help someone else down the line.

Oliver

On Thursday 06 April 2006 18:08, Oliver Iberien wrote:
In order to set the printer setting for openoffice.org-2.0.2 I have to, as
far as I know, run the program
/usr/local/openoffice.org-2.0.2/program/spadmin as root. (The default
settings are for lp and I am using cups.) It's a series of dialogs in
windows and so I've tried to set the display. I get a "no protocol
specified" error.

bsd# setenv DISPLAY ":0.0"
bsd# /usr/local/openoffice.org-2.0.2/program/spadmin
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

I18N: Operating system doesn't support locale "en_US"
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

/usr/local/openoffice.org-2.0.2/program/spadmin.bin X11 error: Can't open
display: :0.0
   Set DISPLAY environment variable, use -display option
   or check permissions of your X-Server
   (See "man X" resp. "man xhost" for details)

I looked at the xhost page and tried:

bsd# xhost +root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

The same thing happened with xhost +. What am I missing?

Oliver

PS Using sudo does not work as for some reason when I try to run spadmin
with sudo, spadmin can't find libraries it needs that are in its own
folder. su-ing gets the same result as running as root, and deleting
~/.openoffice.org-2.0.2 and running spadmin as a normal user changes
nothing -- apparently nothing printer-related is in there
Sorry, guess I should have kept reading. Looks like I misunderstood the problem....

--
Duane Whitty
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to