Kevin Kinsey wrote:
Vayu wrote:

On Thursday 06 April 2006 19:47, Donald T Hayford wrote:
My numeric keypad no longer works under X

Since when?

And, I have to ask, since you didn't mention it ... you've
replaced the keyboard to rule out hardware issues?

except as a way to move the mouse cursor (i.e., no 1-9, etc). The LED changes states when pushed. I've searched through the X.org site but haven't found anything of use. Does anybody know how to fix this? My xorg.conf looks like this:

/Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

<some other stuff>

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

<more stuff>
/

I'm running FreeBSD 6.1-PRERELEASE, with X version 6.9.0. I use KDE as the X desktop.

Thanks for your help,
Don Hayford

I sure don't see anything there that gives a clue.  Have you tried
and duplicated the problem with a different WM?

Kevin Kinsey

I built and installed gnome2-lite and the keypad works correctly. It also works correctly under Fedora Core 4 (dual-boot machine. Sorry I didn't mention that earlier).

So, I suppose I should apologize to X.org and change the title to "Keypad no longer works under KDE 3.5". I presumed the problem was with X and not KDE since I had such trouble with my mouse when I upgraded X to R6 and then saw that X had recently changed the keyboard driver. I don't know exactly when it stopped working, but I'm guessing when I upgraded from KDE 3.4 to 3.5 in early February, 2006.

I googled "kde keypad problem" and found a reference that suggested hiding (renaming) the .kde subdirectory and the ,kderc file, both in the user's home directory. When I restarted X, I had to go through the kde setup again, but the keypad works now.

You guys are geniuses.

Thanks for your time,
Don Hayford

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to