glx doesn't work. both glx and dri are in my xorg.conf, i'm using the nv
driver, i have graphics/dri installed.

[EMAIL PROTECTED] ~]$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.


--
[EMAIL PROTECTED] ~]$ uname -a
FreeBSD daniel.higham.ca 6.1-PRERELEASE FreeBSD 6.1-PRERELEASE #0: Fri Apr
7 23:44:35 ADT 2006     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/MACHINE
i386
[EMAIL PROTECTED] ~]$ pkg_info |grep dri
dri-6.4.1,2         OpenGL hardware acceleration drivers for the DRI

relevent bits of xorg.conf:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Module"
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "xtrap"
        Load  "freetype"
        Load  "type1"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        #Option     "FPScale"                   # [<bool>]
        #Option     "FPTweak"                   # <i>
        Identifier  "Card0"
        Driver      "nv"
        VendorName  "nVidia Corporation"
        BoardName   "NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
        BusID       "PCI:1:0:0"
EndSection
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to