On Wed, 19 Apr 2006 05:23:23 +0600
[EMAIL PROTECTED] wrote:

> >>>>> I have FreeBSD 6.0-RELEASE and optical Microsoft IntelliMouse 
> >>>>> Explorer, USB native, plugged to PS/2 port via it's own
> >>>>> USB->PS/2 adaptor.
> >>>>> When I scroll my mouse wheel up in X11 it acts like "scroll up
> >>>>> + left button one/double-click". For example, in Opera,
> >>>>> Firefox. In MS Windows mouse works correctly.
> >>>>
> >>>> I am running the same mouse in the same way on the same release. 
> >>>
> >>> I have changed settings as Pete advised. Both variants (old and
> >>> new) are working (scrolling) but described effect remains.
> >>> Why I think that scrolling up works as "scroll + left click": for 
> >>> example, in Opera scrolling up at the top of document (when real 
> >>> scroll is impossible) result in marking the word under cursor and 
> >>> appearing context menu for very short time.
> >>
> >> I've been having the same problem since updating to Xorg 6.9.0 two 
> >> months ago. Before that, this problem did not exist for me. Here
> >> are a couple examples of what I see with use:
> >>
> > I know it's only a workaround and not a solution, but at least
> > until you're able to get the rodent behaving the way you like, you
> > can change the setting in Thunderbird preferences.
> > 
> > In v1.5:
> > Edit --> Preferences --> Advanced
> > [Check box]  Wait XX seconds before marking a message as read
> > (2nd item down)
> 
> Effect disappears when mouse is plugged to USB port directly, without 
> adapter. Besides that with ums(4) buttons 6 and 7 works although it
> has the same affect as button 1.
> But there is no ability to power off USB port at the moment it seems
> (http://lists.freebsd.org/pipermail/freebsd-usb/2005-December/001756.html). 
> PS/2 advantage: 'killall moused' results in turning mouse off, for
> USB it doesn't.
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "[EMAIL PROTECTED]"

Maybe this might help you 
These are my usb mouse settings 

/etc/rc.conf
moused_enable="NO"

/etc/X11/xorg.conf
Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "Auto"
    Option      "Device" "/dev/sysmouse"
EndSection

~/.xinitrc
xmodmap -e "pointer = 1 2 3 4 5 8 9 6 7 10 11"

With this config I have no problems
except that when I spin my mouse wheel really fast in firefox or opera
it opens a new page when it goes over a link

All I do now is to scroll more patiently if I want to move fast from the
top of a page to the bottom I use the keyboard

-- 
Reinhold Platzoeder

[EMAIL PROTECTED]
[EMAIL PROTECTED]

http://www.violetlan.net
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to