I recently installed the new binary diablo-java from the FreeBSD Foundation (Thanks much for all your hard work). It installed fine, but it doesn't work properly yet. Firefox about:plugins indicates that diablo-java has been registered.

When I go to www.java.com and choose "verify installation," Firefox crashes as soon as the webpage indicates "Trying test 1" with the error message:


INTERNAL ERROR on Browser End: Listen on server socket failed
System error?:: Invalid argument

----------------------------

Configuration:

FreeBSD 6.0-RELEASE-p6 with SMP kernel
2 x 233MMX Pentium, 256 MB RAM
/etc/make.conf contains CPUTYPE?=pentium-mmx
diablo-jre-freebsd6-1.5.0.06.00.tbz
xorg-libraries-6.9.0
javavmwrapper-2.0_6
firefox-1.5.0.2,1 recompiled and reinstalled after installing
    diablo-java
[all software including operating system and kernel (except diablo-java) compiled on this computer through make, make install, make clean.]


-----------------

pkg_add gave a warning after installing diablo-java that versions for xorg-libraries and javavmwrapper were newer than expected.

------------------------

Another verification that diablo java installed properly:
$ /usr/local/bin/java -showversion
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build diablo-1.5.0-b00)
Java HotSpot(TM) Server VM (build diablo-1.5.0_06-b00, mixed mode)

[snip the rest of the java help messages]


------------------

Thanks for any suggestions.

Rick

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to