-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Mon, 24 Apr 2006, Robert Fitzpatrick wrote:

Trying to install Apache 2.2 via the ports collection and get this make
error where the port is trying to install OpenLDAP 2.2 and conflicting
with my already installed v2.3...

esmtp# make
===>   apache-2.2.0_7 depends on executable: python - found
===>   apache-2.2.0_7 depends on file: /usr/local/bin/perl5.8.7 - found
===>   apache-2.2.0_7 depends on file: /usr/local/bin/autoconf259 - found
===>   apache-2.2.0_7 depends on file: /usr/local/bin/libtool - found
===>   apache-2.2.0_7 depends on shared library: expat.6 - found
===>   apache-2.2.0_7 depends on shared library: ldap-2.2.7 - not found
===>    Verifying install for ldap-2.2.7 in /usr/ports/net/openldap22-client
===>  Installing for openldap-client-2.2.30

===>  openldap-client-2.2.30 conflicts with installed package(s):
     openldap-sasl-client-2.3.20

I have on another server Apache 2.0 running with LDAP 2.3, but the LDAP package 
has been upgraded since Apache was installed. Can someone suggest what is 
necessary to get Apache 2.2 to install with OpenLDAP 2.3.x? Looks from the 
Makefile that WITH_LDAP triggers the support, I also have WITH_OPENLDAP_VER=23 
in the /etc/make.conf file, but no help getting Apache to look at my v2.3.x.

Try WANT_OPENLDAP_VER=23 in /etc/make.conf .

This is handled by Mk/bsd.port.mk and there is no WITH_OPENLDAP_VER.

Joerg

- -- The beginning is the most important part of the work.
                                -Plato
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (FreeBSD)

iD8DBQFETQ1vSPOsGF+KA+MRAr18AJ0URkSjk7O4FETWW8eMv/eDW2MMigCfeq8D
WGQ0A8UkRI9orjSuGWMQT+w=
=MlLO
-----END PGP SIGNATURE-----
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to