On Friday 21 April 2006 00:31, Alex de Kruijff wrote:
> On Thu, Apr 20, 2006 at 10:17:47AM +0000, Ben Paley wrote:
> > Hello,
> >
> > I have Apache 2 running on FreeBSD 6.1-PRERELEASE on a laptop on a small
> > office lan. Whenever one of the other machines (mostly Macs) makes a
> > request for a certain page on my machine, it is delivered succesfully but
> > the file itself is absolutely scrambled beyond recognition into a binary
> > file. Subsequent requests rescramble it into a different but equally
> > nonsense binary.
> >
> > I've looked with a binary editor and it really is completely messed up. I
> > can restore the file from a good archive copy, but every time the same
> > thing happens.
> >
> > The file was originally created on a mac by Flash (it's a 1.1k html file
> > which just embeds a flash movie). Recently I copied it to and from a
> > Solaris box via ftp from an Windows NT machine (although it wasn't opened
> > afaik - a long story, clearly, which also involves a usb flash drive...).
> >
> > Anyone have any ideas? The file itself is inconsequential, but the fact
> > of such blatant and relentless data corruption is very worrying to me! I
> > don't know if it's the file or my system or some combination... I'd
> > really appreciate some advice, I've been staring at it for two days and
> > I'm starting to bite my nails...
> How about setting the permission so that the file can not be changed.
> Then access the file and see if a process complains about not being able
> to change the file?
> P.S. I find it hard to beleave apache2 does this. I run apache2 myself
> and don't have this.

I've set the permissions to 444 and I'm still seeing the same corruption, so 
it must be something running as root, or something quite low level. No 
console messages and I don't really know where to look for error logs - I 
think you're right and it's not apache.

I've started to notice some other strange corruptions - some php files seem to 
become binary on a remote machine, even though my local copies are fine. 
Perhaps it's the server... but we've never had this trouble before, and it 
seems a little too much like what's happening on my machine to be a 
coincidence. One file I tried uploading with two different gui ftp clients 
and via command line, in ascii, binary and auto mode, and again the same 
thing happened each time - my browser complained of unknown ascii characters 
and kate (text editor) told me it was a binary file even though it looked ok. 
I tried changing the encoding and that made no difference.

I am actually quite worried now. There seems to be something holding all these 
occurences together, but I can't quite work out what it is.

Does anyone have any ideas where to look? I'd really appreciate it!

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to