Bigby Findrake wrote:
1. What about backgrounding startx and then exiting your shell?


Errr?  I can do that??? Let's see....
Just tried (startx &; logout). That works pretty well. I guess it never occurred to me. Though had it... I would've thought I'd have had to nohup it.

Works great!  Thanks!


2. Have you tried using "lock -np" instead of vlock?

Actually, I did try lock (though not with the 'p' option).  Somehow the
'p' eluded me in the enormous 10 sentence man page :}.  So when I tried
it... it prompted me for a password.  And I did not like that.  So I
just now tried it again with -np... and although it does not prompt for
the password to use for unlocking... it behaves the same as vlock does.
 It seems to get some input from somewhere and constantly, repeatedly
accepts a phantom key, says its wrong and then prompts, accepts a
phantom key.... on and on.  So unfortunately this does not work (for
me).  Do you get different behavior?  I used 'startx &; lock -np' to test.




On Mon, 17 Apr 2006, Eric Schuele wrote:

Eric Schuele wrote:
Hello,

[hadn't worn my newbie hat lately... so I thought I'd try it on.]

Is there a way to run X via startx and prevent someone from switching back to the console that started it and pressing Ctrl-C, without using DontVTSwitch in my xorg.conf file?

I would like to be able to use multiple virtual consoles. But do not like the idea of someone switching back to *my* virtual console... killing X and having my account available to them. This way I could lock my session via xscreensaver, and walk away. Then someone else could login and use the machine... just not *my* account.

I had envisioned something like a script that did the following:
  #!/bin/sh
  startx &
  vlock

Yet vlock does not like this at all. I was hoping to background startx... and then lock the virtual console. :)

A little more info....
So it appears that vlock works if I "manually" background startx from the console, and then run vlock. but inside the script vlock gets into a loop in which it thinks it is seeing keystrokes... and repeatedly (quickly) says that the password is bad, please try again. It does this forever.

Additionally, the script works just fine for root. It behaves exactly as I would like. It startx and then locks the console.

Lastly, I have done a bit more googling, looking for vlock and startx specifically... and found that (at least in the past) many people have done it this way with success. I'm not sure what I might be doing wrong here.

I did turn up one bug that sounds very much like what I am experiencing but it appears to have been fixed some time ago. I wonder if there is a regression? Anyone using `startx &; vlock` successfully?


Is there anything that might accomplish something similar?

Thanks.



--
Regards,
Eric
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"



/-------------------------------------------------------------------------/
Under deadline pressure for the next week.  If you want something, it
can wait.  Unless it's blind screaming paroxysmally hedonistic ...

                   finger://[EMAIL PROTECTED]
                  http://www.ephemeron.org/~bigby/
                  irc://irc.ephemeron.org/#the_pub
                news://news.ephemeron.org/alt.lemurs
/-------------------------------------------------------------------------/
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"



--
Regards,
Eric

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to