Joerg Pulz wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


On Thu, 27 Apr 2006, Per olof Ljungmark wrote:

openldap-server-2.3.21

How can I make postfix build with this version of OpenLDAP? It wants 2.2...

Thanks

Have a try with WANT_OPENLDAP_VER=23 instead of WITH_OPENLDAP_VER=2.3.21

Thank you, that worked fine!
Now I have the same issue with php5-extensions that also wants the 2.2.7 ldap libraries from openldap22. I cant find a switch here unfortunately.

It's the same thing as for postfix. WANT_OPENLDAP_VER=23 is your friend.
The OpenLDAP version decision is made by Mk/bsd.port.mk if the port uses USE_OPENLDAP=yes like it is in lang/php5/Makefile.ext which is actually the dependency handler of lang/php5-extensions. The default OpenLDAP version is set by Mk/bsd.port.mk and currently it is WANT_OPENLDAP_VER?=22 . I'm currently investigating how many ports will break when we change the system wide default of WANT_OPENLDAP_VER from "22" to "23". If anything runs fine, we will probably have "23" as default soon.

You should add "WANT_OPENLDAP_VER=23" to your /etc/make.conf to get rid of this problem, otherwise you will hit the same problem again for every OpenLDAP dependent port.

Thank you very much for this valuable piece of information! I must admit I've been lazy here, I could have found this out myself through RTFM.

Per olof
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to