Kris Kennaway wrote:
On Thu, Apr 27, 2006 at 08:59:42PM -0500, Brian John wrote:
Hi, I just upgraded my ports and now all of my video players either won't install, or they won't start up. I've tried 4 different ones, here is what happens with each:

vlc: won't install
/usr/local/lib/libmatroska.so: undefined reference to `libebml::CodedSizeLength(unsigned long long, unsigned int)'
gmake[2]: *** [vlc] Error 1
gmake[2]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-0.8.4a'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-0.8.4a'
gmake: *** [all] Error 2
*** Error code 2

totem: won't start up
[EMAIL PROTECTED] /usr/ports/multimedia/totem]$ totem &
[1] 8150
[EMAIL PROTECTED] /usr/ports/multimedia/totem]$ /libexec/ld-elf.so.1: Shared object "libglib-2.0.so.600" not found, required by "libgnome-keyring.so.0"

xine: this one starts up, but then closes right away, with no error

mplayer: won't install, get several errors similar to this
/usr/X11R6/lib/libxmms.so: undefined reference to `gtk_widget_get_type'
/usr/X11R6/lib/libxmms.so: undefined reference to `gtk_vbox_new'
gmake: *** [mencoder] Error 1
*** Error code 2

Can someone please help me out?

You didn't upgrade your ports completely; you have an inconsistent mix
of old and new libraries on your system.  portupgrade -a, or if that
fails, portupgrade -fa.

Kris
I was using portmanager to upgrade. I've always used this before and it's worked fine. I just type portmanager -u. Does that not work anymore?

Thanks

/Brian
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to