Gerard Seibert wrote:
Kris Kennaway wrote:

On Thu, Apr 27, 2006 at 09:22:45PM -0500, Brian John wrote:
Kris Kennaway wrote:
On Thu, Apr 27, 2006 at 08:59:42PM -0500, Brian John wrote:
Hi, I just upgraded my ports and now all of my video players either won't install, or they won't start up. I've tried 4 different ones, here is what happens with each:

vlc: won't install
/usr/local/lib/ undefined reference to `libebml::CodedSizeLength(unsigned long long, unsigned int)'
gmake[2]: *** [vlc] Error 1
gmake[2]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-0.8.4a'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-0.8.4a'
gmake: *** [all] Error 2
*** Error code 2

totem: won't start up
[EMAIL PROTECTED] /usr/ports/multimedia/totem]$ totem &
[1] 8150
[EMAIL PROTECTED] /usr/ports/multimedia/totem]$ /libexec/ Shared object "" not found, required by ""

xine: this one starts up, but then closes right away, with no error

mplayer: won't install, get several errors similar to this
/usr/X11R6/lib/ undefined reference to `gtk_widget_get_type'
/usr/X11R6/lib/ undefined reference to `gtk_vbox_new'
gmake: *** [mencoder] Error 1
*** Error code 2

Can someone please help me out?
You didn't upgrade your ports completely; you have an inconsistent mix
of old and new libraries on your system.  portupgrade -a, or if that
fails, portupgrade -fa.

I was using portmanager to upgrade. I've always used this before and it's worked fine. I just type portmanager -u. Does that not work anymore?
No idea, I don't use portmanager.


Assuming you have an updated ports collection, it should work fine It
does on my system.

I would recommend that you update your ports again and then run
'portmanager -u -f -y -l' and see if that fixes the problem. At the very
least, a log file will  be created '/var/log/portmanager.log' that might
help track down the problem.


Hi, thanks for the advice. I tried that command and it's been updating for a couple of days (takes so long because of the prompts that come up that stop the installs). Anyway, now portmanager always gets to a certain point and my computer reboots. I looked in the logfile and there isn't much there, this is at the end of the file:
Sun Apr 30 16:36:17 2006
kdelibs-3.4.2_1 /x11/kdelibs3 OLD kdelibs-3.5.2_1 /x11/kdelibs3
Any idea what could be causing this?

Thanks again for the help

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to