We recently replaced FreeBSD 4.5 with 6.0-RELEASE on a pair of servers.
One of the servers runs rsync to copy its contents to the other server,
over a NFS mount. Everything worked just fine under 4.5, but with 6.0,
we're seeing dozens of these errors every rsync:

May  2 14:00:59 xxx1 kernel: nfs server xxx2:/usr: not responding

The rsync does eventually complete successfully. The NFS client system
uses the em0 driver on a gigabit port, and the NFS server system uses
the fxp0 driver on a 100Mbit/full duplex port. The client system
doesn't come close to 100Mbit during the rsync (or otherwise) -- more
like 5Mbit. Neither server is what I'd consider "busy" -- they're actually
basically idle unless this script or some crons are running.

We're using NFSv3 soft, interruptable mounts. We've tried using TCP and
UDP, and have tried different -r and -w sizes, up to 32768 each. We've tried
it with and without nfsiod.

We haven't tried changing the mount_nfs -D option, because that seems
like it would only serve to mask the real problem, whatever that is.

a) Is this a real problem, or simply a reporting problem? What exactly is it
reporting if it's not a real problem?
b) If you've had this trouble before, what settings have you used to fix it?

Another issue is we're not seeing the usual "is alive again" message
you'll usually see when the server becomes unavailable and then returns.

I searched the PRs before posting this, but if there's a PR you know about
I could add a followup message to it. If you need other info, I can provide
that as well.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to