Hi!

I currently just fixed moused to start up using my laptop's mousepad in
/etc/rc.conf using the following options:

moused_enable="YES"
moused_port="/dev/psm0"
moused_flags=""     #This is another problem of mine, I can't get the four
extra buttons on my mousepad to work because I don't know what to specify
with -z, but this isn't the point of this post
moused_type="ps/2"

so after booting and hooking up my USB mouse, I type:

ps -aux | grep moused
root      1019  0.0  0.1  1208   752  ??  Is    8:32PM   0:00.00 moused -p
/dev/psm0 -t ps/2
root 1275 0.0 0.2 1208 784 ?? Ss 8:54PM 0:00.12/usr/sbin/moused -p /dev/ums0 -t ps/2 -I
/var/run/moused.ums0.pid

So, I can tell that it is using the same defaults that I specified in my
/etc/rc.conf file, but I can't figure out how to differentiate between the
two in /etc/rc.conf.  I tried running usbd -vd to figure out what the device
information, so I could enter it into /etc/usbd.conf file:

device "Basic Optical Mouse, Microsoft"
       vendor  0x045e
       product 0x0084
       release 0x0000
       attach '"/usr/sbin/moused -p /dev/${DEVNAME} -t auto -z "4 5" -I
/var/run/moused.${DEVNAME}.pid"'

Which when I kill everything and run usbd and attach my device again, I
still get the same output from ps -aux | grep moused.  Also, I noticed while
I killed usbd, I can still attach my usb mouse, so where should I be looking
in order to get my usb mouse to attach differently than stated in my
rc.conffile?

Thanks,
Jon
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to