On Saturday 06 May 2006 13:28, Arno Schleich wrote:
> Dear all,
>
> I have observed the following behavior in portupgrade:
>
> The operation
>
> portugrade -a
>
> results in a repetitive rebuild of the package database whenever the
> database is accessed.
>
> [Updating the pkgdb <format:dbm_hash> in /var/db/pkg ... Inappropriate file
> type or format - /var/db/pkg/pkgdb; rebuild needed] [Rebuilding the pkgdb
> <format:dbm_hash> in /var/db/pkg ... - 435 packages found (-0 +435)
> ...........................................................................
>............................................................................
>............................................................................
>............................................................................
>............................................................................
>........................................................ done]
> --->  Backing up the old version
> [Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... Failed
> `Inappropriate file type or format'; rebuild needed] [Rebuilding the pkgdb
> <format:bdb1_btree> in /var/db/pkg ... - 435 packages found (-0 +435)
> ...........................................................................
>............................................................................
>............................................................................
>............................................................................
>............................................................................
>........................................................ done]
> --->  Uninstalling the old version
> [Updating the pkgdb <format:dbm_hash> in /var/db/pkg ... Inappropriate file
> type or format - /var/db/pkg/pkgdb; rebuild needed] [Rebuilding the pkgdb
> <format:dbm_hash> in /var/db/pkg ... - 435 packages found (-0 +435)
> ...........................................................................
>...........................
>
>
> Is this a bug or a feature ?
>
> What can be done to suppress this behavior of portupgrade -a ?
>
> Thanks, Arno

Sounds like your pkgdb is corrupt. Try doing "pkgdb -fu" (without the quotes), 
if that doesn't work rename or rm /var/db/pkg/pkgdb.db and run the command 
again to build a new pkgdb.

Beech



-- 

---------------------------------------------------------------------------------------
Beech Rintoul - Sys. Administrator - [EMAIL PROTECTED]
/"\   ASCII Ribbon Campaign  | Mangohealth
\ / - NO HTML/RTF in e-mail  | 201 East 9Th Avenue Ste.310
 X  - NO Word docs in e-mail | Anchorage, AK 99501
/ \  - XanGo - http://www.mangohealth.org
---------------------------------------------------------------------------------------











Attachment: pgpb3J15aF3Ui.pgp
Description: PGP signature

Reply via email to