Gerard Seibert wrote:

>Michael D. Norwick wrote:
>>freebsd 6.1 RELEASE Compaq Proliant SMP PII-200 (smp modified kernel)
>>Over a week ago I was trying to rebuild Xorg and ran into an issue with
>> not found for 'fc-cache'.  This was my fault because
>>earlier I wanted  expat2, built it from the 'ports' collection tarball
>>current (at that time) from, and apparently broke
>>the dependency for  Following the advice given to another
>>user on freebsd-questions, I did pkgdb -F then portupgrade -a in order
>>to fix the dependencies and get Xorg 6.9.0.  Little did I know that it
>>would take over a week to upgrade and rebuild 119 installed packages on
>>my PII-200 SMP Proliant.  Other than a couple of burps with boost-python
>>and postgresql, the upgrade has kept chugging along.  Today, I am almost
>>to the end and the Mozilla build flaked out.  No worries on that yet,
>>but the script suggested doing pkgdb -F again and restarting
>>portupgrade.  I dutifully followed and when portupgrade restarted it
>>tried to build bash31aborted with the following error which I do not
>>understand.  When the 'make bash31' stopped on error the first time I
>>manually downloaded the whole bash31 file set again to
>>/usr/ports/distfiles/bash from and re-ran portupgrade -a.  It
>>stopped again with the same error.  What is happening here?
>>=> MD5 Checksum mismatch for bash/bash31-010.
>>=> SHA256 Checksum mismatch for bash/bash31-010.
>>And then;
>>=> Attempting to fetch from
>>fetch: bash31-010: local modification time does not match remote
>Personally, I would have used 'portmanager' to fix the situation.
>Running it like this: portmanager -u -f -l -y should have corrected your
>In any even, delete everything in the /usr/ports/distfiles directory.
>Next, update your entire ports collection. If you are still going to use
>portupgrade, then definitely run the pkgdb -afFuv. It will give you a
>better idea of what is happening. You might also consider running
>portsdb -Uu if you have the time. It couldn't hurt. If you decide to use
>portmanager, those last two steps are not required.
>Good luck!

>>Are you sure you removed the distfiles or did you try to download over them?  
>>You should delete them.

I downloaded over them so I will take both suggestions and delete the whole 
mess and rebuild.  The Handbook and The 'Complete' book are not too clear on 
the advantages of portupgrade over portmanager.  Right now the build(upgrade) 
got to 'gimp-print' and is freaking out with:

'warning: traditional C rejects ISO C style function definitions' for every .c 
file in the package due to not hiding #pragma's from traditional C in the 
header files.  Ho-Hum.  Maybe a problem with autoconf and friends???  
Soldiering on.

Thank You for the help.


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to