Hi All,

I'm new to FreeBSD and a first time poster to this
list. I have used Linux for several years but would
like to see what FreeBSD is like.

tiny# uname -a
FreeBSD tiny.brc.localnet 
6.0-RELEASE FreeBSD 6.0-RELEASE #0: 
Thu Nov  3 09:36:13 UTC 2005  
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC 
i386

The daily security report has identified 10 problem
applications.  So far, I have fixed one app,
lynx-2.8.5 by deleting it with pkg_delete.  Then added
the 2.8.5_2 package.

Simple, no dependancy problems.

Next, I tried to uninstall ruby-1.8.2_4 but found two
dependencies:

  ruby18-bdb1-0.2.2
  portupgrade-20041226_7

which uninstalled with no problem.  Then on to
uninstall of ruby-1.8.2_4 :

tiny# pkg_delete ruby-1.8.2_4
pkg_delete:
'/usr/local/share/ri/1.8/system/created.rid' fails
original MD5 checksum - not deleted.
pkg_delete: unable to completely remove directory
'/usr/local/share/ri/1.8/system'
pkg_delete: couldn't entirely delete package (perhaps
the packing list is
incorrectly specified?)
tiny#

tiny# ls /usr/local/share/ri/1.8/
ls: /usr/local/share/ri/1.8/: No such file or
directory

tiny# ls /usr/local/share/ri/1.8/system
ls: /usr/local/share/ri/1.8/system: No such file or
directory
tiny#

I'm not sure how to proceed with this one.

A different package problem:

tiny# pkg_delete ghostscript-gnu-nox11-7.07_13
tiny# pkg_add -r
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/ghostscript-gnu-nox11-7.07_15.tbz
Fetching
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/ghostscript-gnu-nox11-7.07_15.tbz...
Done.
pkg_add: package 'ghostscript-gnu-nox11-7.07_15'
conflicts with ghostscript-gnu-7.07_13
pkg_add: please use pkg_delete first to remove
conflicting package(s) or -f to force installation

tiny# pkg_delete ghostscript-gnu-7.07_13 
pkg_delete: package 'ghostscript-gnu-7.07_13' is
required by these other packages
and may not be deinstalled:
gv-3.6.1
apsfilter-7.2.6
ggv-2.8.5
gnome2-2.10.2
tiny#

Do I really have to delete / update all these apps
just to update ghostscript.

One last example:

tiny# pkg_delete libiconv-1.9.2_1
pkg_delete: package 'libiconv-1.9.2_1' is required by
these other packages
and may not be deinstalled:
gettext-0.14.5
windowmaker-0.92.0
libgpg-error-1.0_1
... plus another 125 packages

Good grief, what am I doing wrong?  This cannot be the
correct way to manage errata.

Please accept my apologies for the long message, I
wanted to give a fuller picture of these problems.

Jim


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to