On Wed, May 17, 2006 at 08:22:03AM -0500, Derek Ragona wrote:
> Sounds like you recently upgraded but don't have the compatible libraries 
> in /etc/make.conf make sure you have:
> COMPAT4X=       yes
> 
> And then rebuild the world.
> 
> You might also want to have:
> options         COMPAT_FREEBSD4
> In your kernel config file.

The real question is why do you have binaries depending on old system
libraries.  The answer is probably that you upgraded from a previous
branch of FreeBSD (e.g. 4.x -> 6.x) but neglected to rebuild all your
installed ports, so they now have an inconsistent mix of old and new
libraries.

portupgrade -af or similar to repair the damage.

Kris

Attachment: pgpa3skdUyw0p.pgp
Description: PGP signature

Reply via email to