On Mon, 2006-05-22 at 19:51 +1000, Mikhail Goriachev wrote:
> none none wrote:
> > Hi
> >   I fear that this time a messed up big time. I have two hard drives one 
> > with Windows XP (40G) and another with FreeBSD 6.1  (10G). Eveything was ok 
> > until I decided i wanted to mount my windows drive to FreBSD (i run KDE as 
> > GUI). I followed the instruction from OnLamp.com and since i wanted the 
> > whole process to be automated on every boot i added the following lines in 
> > /etc/fstab using ee: 
> >   /dev/ad0s1  /windows        ntfs   rw       1     1
> >  
> >   and everything looked normal until i rebooted! now when i choose FreeBSD 
> > on the bootmanager it starts looking ok and ends up with the following:
> >   fsck: exec fsck-ntfs for /dev/ad0s1 in /sbin:/usr/sbin: No such file or 
> > directory
> >   Unknown error: help!
> >   init /bin/sh on /etc/rc terminated abnormaly, going to single user mode
> >   Enter full pathname of shell of RETURN for /bin/sh
> >    
> >   if i enter single user mode it dasen't seem to recognize many commands: 
> > starrtx, ee, pico, emacs etc so i cannot change my /etc/fstab in case this 
> > is the problem. 
> >    
> >   Moreover now i am unable to enter windows as the bootmanager when i ask 
> > him to load the DOS disk it just reboots the system. I even tried to leave 
> > only the (40G) on the machine but thens it just crashes right after memeory 
> > check. I am seriously in need for some help, if anyone could suggest 
> > anything i would appreciate it a lot. Thanks in advance
> >   andreas Sotriakopoulos
> Hi,
> This one is gonna sound funny. I once had a mistype in /etc/fstab
> myself. I solved it by pulling the hard drive off the box, mounting it
> on another one and then I modified the file. I guess you could do the
> same if you have a spare FreeBSD box lying around. But there must be a
> better way doing it though.
> Cheers,
> Mikhail.
The 'ed' editor is in /bin, and so is available at single-user boot.  It
is a real antique, but if you have a copy of the manual it is not too
hard to correct /etc/fstab.

'ee' is in /usr/bin
Mike Jeays
http://ca.geocities.com/[EMAIL PROTECTED]

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to