First of all, to make it easier to read and especially to respond to
your posts, please break your lines at about 72 characters length.
You can either set your Email editor to do that or just hit ENTER
at about that length of each line (which is what I do).

> Hi
>   I fear that this time a messed up big time. I have two hard drives one 
> with Windows XP (40G) and another with FreeBSD 6.1  (10G). Eveything was 
> ok until I decided i wanted to mount my windows drive to FreBSD (i run KDE 
> as GUI). I followed the instruction from OnLamp.com and since i wanted the 
> whole process to be automated on every boot i added the following lines 
> in /etc/fstab using ee: 
>   /dev/ad0s1  /windows        ntfs   rw       1     1

The only thing I see wrong, as long as the "ntfs" is correct might be
wanting 'ro' instead of 'rw' and '2   2'  instead of  '1    1'.  Try
modifying those.

>   and everything looked normal until i rebooted! now when i choose FreeBSD 
> on the bootmanager it starts looking ok and ends up with the following:
>   fsck: exec fsck-ntfs for /dev/ad0s1 in /sbin:/usr/sbin: No such file or 
> directory
>   Unknown error: help!
>   init /bin/sh on /etc/rc terminated abnormaly, going to single user mode
>   Enter full pathname of shell of RETURN for /bin/sh
>   if i enter single user mode it dasen't seem to recognize many commands: 
> starrtx, ee, pico, emacs etc so i cannot change my /etc/fstab in case this 
> is the problem. 

Yes.   Generally none of those extra things are availiable in single user.
Single user is minimal and does not have services started nor anything
but root mounted and root is mounted in a special non-write way.

You need to learn enough 'vi' editor to fix problems in these types
of situations because generally vi will be available even when the
others are not usable.    It is easy to use and you may end up finding
yourself using it in preference to the others for plain text editing
after you get accustomed to it.    There are lots of tutorials for
using vi.  One is at:   http://scnc.k12.mi.us/howto/edit/vi.html

So, you need to:
  fsck -p /
  mount -u /
  vi /etc/fstab
     - fix the bad line or comment it out by starting it with a # (pound sign)
  shutdown -r now

Then, it should boot and you can work with your habitual tools.
>   Moreover now i am unable to enter windows as the bootmanager when i ask 
> him to load the DOS disk it just reboots the system. I even tried to leave 
> only the (40G) on the machine but thens it just crashes right after memeory 
> check. I am seriously in need for some help, if anyone could suggest 
> anything i would appreciate it a lot. Thanks in advance

I don't know about the MS-Windos problem, but it sounds like you may
have overwritten some piece of their boot code.     Fix the other problem
so you can get in to FreeBSD first and then you might be able to use it
to find the Windos problem and fix it - maybe by putting an MBR in the
right place.


>   andreas Sotriakopoulos
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to