Please let me know if this is not the right list to ask this.

I have a Tyan 4882 4 CPU (dual core) Opteron, running amd64 FreeBSD 6.0 Release, 8 gig ram (all recognized), SCSI 15K Seagate ST373454LC drives. BIOS is running all stock settings.

It's job is to run Apache (ran 2.1 now latest 2.2, have tried threaded and prefork configurations).

It runs blisteringly fast and appears to have no problems except one. It hangs after running 5 to 7 days, once after 2 days. There are no error messages in the log and it just stops responding. The only solution is to physically go press the reset button where as it recovers perfectly every time (after fixing the messed up any messed up file system links).

The system is a very high traffic web server. It services html pages and trivial Perl CGI forum software running without any particular privilege. Prior to a hurried installation, I ran a high volume bench mark against it on my own lan hitting it with 10K of requests for a trivial web page look up and did produce a hang but the person needing the system really needed it that day. Because of that I've tried two versions of Apache and various MPMs all with the same result. I think Apache may be a red herring in this. I also discovered that it's running off an UPS rated lower than it's power requirements though only under extreme conditions, the UPS is being replaced this week. The hang seems too consistent to be power but perhaps not.

I would like to know if anyone has heard of such an issue with amd64 6.0 Release and what debugging processes might have been used to get around it. I have dmesg and more *stat information if that would help.

Thank you in advance,
Chris
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to