Greetings,

I had a server running FreeBSD 6.0 Release with openldap 2.3.20 running
fine (along with postfix, cyrus-sasl, courier-imap, bdb-4.3, etc.) I
needed to move the system to new hardware, so I rebuild it using 6.1
Release. The ports tree has been updated so openldap 2.3.23 is current.
After building and installing this port, and copying my config files from
my 6.0 system, openldap server will not start. It silently quits with no
error or log entries when run using /usr/local/etc/rc.d/slapd start.

However typing:
/usr/local/libexec/slapd -Tt

yields:
/libexec/ld-elf.so.1: /usr/local/lib/libldap_r-2.3.so.2: Undefined symbol
"pthread_getconcurrency"

My build options for openldap are:

%cat /var/db/ports/openldap23/options
# This file is auto-generated by 'make config'.
# No user-servicable parts inside!
# Options for openldap-server-2.3.23
_OPTIONS_READ=openldap-server-2.3.23
WITH_SASL=true
WITHOUT_PERL=true
WITH_SHELL=true
WITHOUT_ODBC=true
WITHOUT_SLP=true
WITHOUT_SLAPI=true
WITH_TCP_WRAPPERS=true
WITH_BDB=true
WITHOUT_ACCESSLOG=true
WITHOUT_AUDITLOG=true
WITHOUT_DENYOP=true
WITHOUT_DYNGROUP=true
WITHOUT_DYNLIST=true
WITHOUT_LASTMOD=true
WITHOUT_PPOLICY=true
WITHOUT_PROXYCACHE=true
WITHOUT_REFINT=true
WITHOUT_RETCODE=true
WITHOUT_RWM=true
WITHOUT_SYNCPROV=true
WITHOUT_TRANSLUCENT=true
WITHOUT_UNIQUE=true
WITHOUT_VALSORT=true
WITHOUT_ACI=true
WITH_DYNAMIC_BACKENDS=true
%

I don't know if this is a problem with the db43 library or something else.
Any pointers are welcome.

Thanks,

Jon


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to