Svein Halvor Halvorsen wrote:
Tom K wrote:
I'm running PC-BSD, with FreeBSD 6 under the hood. The device is a
Netgear MA111, with Prism 2.5 chipset, which dmesg shows as

ugen1: vendor 0x0846 product 0x4110, rev 1.10/1.32

This is what I've done so far:

- Installed the kernel source in /usr/src/sys.
- Copied over the .inf and .sys files from the WinXP driver
- Run ndisgen, which reported success
- Copied the new module to /boot/kernel
- kldload ndis and kldload new_module

No ndis interface is created, and dmesg shows the following messages:

no match for USBD_CreateConfigurationRequestEx
no match for USBD_ParseConfigurationDescriptorEx

I can't find any reference anywhere to these errors, or anything
like them. I'd be grateful for any suggestions.
:
Minor update, if anyone's interested - I've now tried it on freebsd 6.1,
with the same result.

Windows NDIS device drivers work because the co-called Project Evil is
emulating the NDIS subsystem of Windows, effectively tricking these
drivers into believing they run under Windows.

However, to support Windows drivers for USB networking devices, would
require emulation of the USB subsystem in Windows as well. This is not
the case for FreeBSD today.


        Svein Halvor

Thanks Svein. That's exactly the kind of definitive answer I was looking for.

ndiswrapper, the equivalent Linux project, does handle USB devices, so I thought I might be lucky with Evil.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to