Sergey Matveychuk wrote:
Michael Collette wrote:
This problem only occurs when using portupgrade.  Both pkg_delete and
pkg_deinstall work without error.  Also, everything else in the process
that portupgrade goes through appears to work properly.  Just that
/var/db/pkg directory won't delete when NFS mounted.

Have you tried the last (2.1.1) version?
I've fixed a few problems and one of them looks like yours. But it's not
relate to NFS however.

No luck. I was back on 2.0.1 which I upgraded with pkg_delete and pkg_add. Still the exact same error with deleting the /var/db/pkg directory.

Like I mentioned earlier, we've been going through the source code on this, libraries and all. If you'd like to toss some tweaks for me to test out off list I'd be one very motivated tester here. This glitch may really complicate my network setup here, so doing whatever it takes to fix this is high on my priority list.

Just a thought for an ugly hack, but might it be possible to force a check for that directory after it has supposedly been deleted, and if it exists manually delete it?

Thanks for getting back with me on this. Going to continue to muck around with things a bit here to see if we can stumble across something that helps.

Later on,
Michael Collette
IT Manager
TestEquity LLC
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to