Mike Hunter wrote:
On Jun 05 at 21:39, "Eric Schuele" wrote:

Mike Hunter wrote:
Hey everybody,

I'm having a frustrating X problem.  I installed X via portupgrade and
hacked /etc/ttys to enable xdm.  I can log in successfully both as root
and as a non-priv user, but either way I get to a screen that says:

Session Menu

Load Session # Delete Session # Break Lock # Default/Fail Safe # Cancel

But if I disable xdm and simply use startx, it launches X and my window
manager fine.  I tried deleting my .xinitrc but that didn't help.

I have a feeling some X component isn't in place.  I tried compiling gdm
as a replacement but that didn't help (same symptoms).  I was able to run
gdmsetup (or was it gdmconfig?) by logging into gdm in fail-safe mode, and
I could change some of the GDM settings, but I didn't see anything that I
could twist to fix the problem.

FreeBSD 6.1-RELEASE May 12
xorg-6.9.0

For xdm:
copy your .xinitrc to .xsession and see if that helps.

gdm:
is a bit more complicated.

Thanks!  It did fix the xdm side and it did not (as you predicted) fix
gdm.

NP.  Glad it fixed it.


What am I missing?  What's supposed to be the difference between .xinitrc
and .xsession?

The difference... well... for your intents and purposes, .xinitrc is run via 'startx', while .xsession is used by xdm. But that's not really a good answer to the question. Google will be your friend here.


How would I fix it for gdm?

Try this:
http://lists.freebsd.org/pipermail/freebsd-questions/2006-April/119887.html


Thanks again!

Mike



--
Regards,
Eric
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to