On 6/7/06, Nick Withers <[EMAIL PROTECTED]> wrote:
On Wed, 07 Jun 2006 15:23:18 +0700
Roger Merritt <[EMAIL PROTECTED]> wrote:

> At 04:35 PM 6/7/2006 +1000, you wrote:
> >On Wed, 07 Jun 2006 12:13:29 +0700
> >Roger Merritt <[EMAIL PROTECTED]> wrote:
> >
> > > I'm thoroughly puzzled. Over the weekend I transferred my FreeBSD
> > system to
> > > a new hard drive. Through laziness I didn't follow the instructions and
> > had
> > > to make a completely new install. Everything now seems to be working the
> > > way it should, Apache, MySQL, PHP, syslog, Samba -- except natd.
> > Everything
> > > starts on boot-up as it should -- except natd. I can start it manually
> > from
> > > the command line after booting up and logging in and it works fine, but I
> > > can't tell what's going on that it's failing to start.
> > >
> > > My /etc/rc.conf contains the following:
> > >
> > > # This file now contains just the overrides from /etc/defaults/rc.conf.
> > > defaultrouter="203.151.134.1"
> > > gateway_enable="YES"
> > > hostname="poppy.international.stjohn.ac.th"
> > > ifconfig_ed0="inet 10.3.16.125 netmask 255.255.255.0"
> > > ifconfig_ed1="inet 203.151.134.104  netmask 255.255.255.0"
> > > router_enable="YES"
> > > firewall_enable="YES"
> > > firewall_type="OPEN"
> > > firewall_quiet="YES"
> > > natd_enable="YES"
> > > natd_interface="ed1"
> > > ipv6_enable="YES"
> > > linux_enable="YES"
> > > moused_enable="YES"
> > > moused_port="/dev/sysmouse"
> > > moused_type="auto"
> > > screen="daemon"
> > > nfs_client_enable="YES"
> > > sshd_enable="YES"
> >
> >That looks alright to me...
> >
> > > What can I do to get some indication of where the problem is?
> >
> >Are there any error messages relating to IPFW / natd on boot?
>
> No, or at least none I could see. That's why I've asked for help.
>
> >What version of FreeBSD are you running?
>
> 6.1-STABLE

Perhaps there's something wrong in the branch at present...?
Doubtful, I guess.

> >What's the command
> >you're running that _does_ launch natd successfully?
>
> "/sbin/natd -n ed1". I hadn't thought about "/etc/rc.d/natd start" until
> someone suggested it, but that works too and reads the interface from
> /etc/rc.conf.
>
> >  What's the
> >output of "ls -l /etc/rc.d/natd"?
>
> [poppy] ~# ls -l /etc/rc.d/natd
> -r-xr-xr-x  1 root  wheel  978 May 31 09:52 /etc/rc.d/natd

Hmmm... Well that all seems OK, then.

The only other thing I can think of is that the
'router_enable'="YES"' line's creating dramas.

As I understand it, this'll cause /etc/rc.d/routed to attempt to
launch the routing daemon specified by a 'router="..."' line,
which you don't appear to have. I don't think this'd interfere
with natd anyway, but I don't really understand what the hell's
going on in /etc/rc.d/routed.

Sorry I can't be more helpful!
--

I don't run route(daemon) so I don't know about router_enable, but
here is what I have in my rc.conf to get natd working:

#router stuff
natd_program="/sbin/natd"
natd_enable="YES"
natd_interface="rl0"
natd_flags="-dynamic -f /etc/natd.conf"
gateway_enable="YES"

So I use gateway_enable not router_enable.

I don't know if this applies to your problem completely, but might be
worth a shot.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to