Joe Auty wrote:

On Jun 18, 2006, at 1:28 PM, Alex Zbyslaw wrote:

Joe Auty wrote:

On Jun 15, 2006, at 6:16 AM, Alex Zbyslaw wrote:

Joe Auty wrote:

jauty# python -v /usr/local/mailman/bin/qrunner
# /usr/local/lib/python2.4/getopt.pyc matches /usr/local/lib/ python2.4/
import getopt # precompiled from /usr/local/lib/python2.4/ getopt.pyc
# /usr/local/mailman/bin/paths.pyc matches /usr/local/mailman/ bin/
import paths # precompiled from /usr/local/mailman/bin/paths.pyc

OK, you just ran qrunner successfully without getting the error you were getting earlier about getopt. Doesn't matter that all you got was help, it found *everything* that it tried to import.

I missed the start of this thread. How did you run qrunner to get your earlier error and where did the error appear? I think you said the rc script. If it's not too big can you post it? Or compare it against your working mailman?

My Mailman rc script (exactly identical to the one on my working machine):

You're getting your error when mailman starts at boot time; is that right?

If so, what happens if you try as root (csh):

# sh -x /usr/local/etc/rc.d/ start

(you might have to check the exact name of the rc.d script).

If this starts mailman then something bizarre is going on.

If you get the same error as usual, then judicious snippets with the error and prior context.

Running the RC script under sh, csh, and bash yields the same error spew....

I've attached the errors spewed out in their entirety:

Sorry, the csh/sh distinction should have been edited out by me - I was redirecting the output in my first edit then took it out. However, the point was to run with sh -x as that will trace execution and might find where <prefix> has been written.

Can you try:

$ ls /usr/local/etc/rc.d/mailman*

$ ls /etc/rc.d/mailman*

(in case some old script has hung around)

$ find /usr/local/mailman -type f -exec egrep -H  '<prefix>' {} \;

(to try to find <prefix> somewhere in mailman install)

and if that finds nothing

$ sh -x /usr/local/etc/rc.d/ start

[from mailman list]

One wild guess - look at bin/ It should contain real paths as
definitions for 'prefix' and 'exec_prefix'. If it's wrong, then so
probably are cron/ and scripts/ (and who knows what

We tried looking in that first file a couple iterations ago :-( Above I've tried looking in others but I don't think that will be it. don't think it's the mailman install per se as you ran qrunner from the command line and it worked. Try again to be sure:


and you' should get the help message and not an import error.


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to