hi all,
I am having some problems when installing ports that use GLIB 1.x , and I
*also* have glib 2.x installed. I have, of course, packages that need 2.x.

when building the pkgs that need glib 1.x (pretty much any package) i get:
[....]
checking for glib-config... /usr/local/bin/glib12-config
checking for GLIB - version >= 1.2.0...
*** 'glib-config --version' returned 1.2.10, but GLIB (2.10.3)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file
config.cache *** before re-running configure
no
configure: error: glib test failed
[...]

The way i read this is that the build process gets an answer from glib-config
(glib 1.x), but then it detects version 2.
via the pkg system and bails out.

I haven't been able to figure out how to use the GLIB_CONFIG variable
properly,as the glib-config file it's finding *IS* the correct one
( glib-config does not exist in 2.x).

Is the only alternative to uninstall glib2. while i'm building pkgs that need
glib1 ? 

thanks in advance,
Beto
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to