Warren Liddell <[EMAIL PROTECTED]> writes:

> im Running FreeBSD 6.1-STABLE
>
> You should build `devel/apr-svn' with db4 support to use subversion with it.
> Please rebuild `devel/apr-svn' with option `APR_UTIL_WITH_BERKELEY_DB=yes' 
> and 
> try again.
>
> Or you can disable db4 support. Only 'fs' repository backend will be 
> available.
> To disable db4 support, define WITHOUT_BDB.
>
> *** Error code 1
>
> Stop in /usr/ports/devel/subversion.
>
> Despite what it sais .. i have no idea on how to do what its saying

something like:

# cd /usr/ports/devel/apr-svn
# make deinstall
# make install APR_UTIL_WITH_BERKELEY_DB=yes

(or use pkgtools if you prefer; probably more convenient)

>                                                                     or why i 
> need to do it when it previously installed fine.

The new version of subversion obviously needs features that the
previous version did not.  You do *not* "need" to do it; you can 
stick with the old version of subversion if you prefer.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to