On Thu, Jan 02, 2003 at 01:42:03PM -0500, Bruce Campbell wrote:
> I don't have it enabled:
>   hw.ata.tags: 0
> I've manually set:
>   atacontrol mode 0 UDMA33 UDMA33
> and the problem has not recurred.
> -- 
> Bruce Campbell
> Engineering Computing
> CPH-2374B
> University of Waterloo
> (519)888-4567 ext 5889
> ----------------------------------------
> This mail sent through www.mywaterloo.ca
> To Unsubscribe: send mail to [EMAIL PROTECTED]
> with "unsubscribe freebsd-questions" in the body of the message
> end of the original message

Yesterday I checked the drive ad6 with the Drive Fitness Test program from IBM.
Both quick and advanced test returned that the drive is ok. I then ran the test
against ad0 (the backup drive): the quick test showed that the drive was
defective because of "Excessive Shock". Re-executing the test gave same result.
I rebooted the system and disabled the S.M.A.R.T. option for the drive attached
to the motherboard's controller (i.e. the backup drive). Re-executing the quick
test showed that the drive is ok!

After 16 hours of uptime and one level-0 file system dump all drives are still
using UDMA100.

If for some reason the system will fall back again to PIO4 mode I will try to
remove the two following options from the kernel:

# ISA optimization
options     AUTO_EOI_1
options     AUTO_EOI_2

If the problem won't still be solved then I will try in order the following:
- disable tagged queuing
- buy different hardware!

        Francesco Casadei
You can download my public key from http://digilander.libero.it/fcasadei/
or retrieve it from a keyserver (pgpkeys.mit.edu, wwwkeys.pgp.net, ...)

Key fingerprint is: 1671 9A23 ACB4 520A E7EE  00B0 7EC3 375F 164E B17B

Attachment: msg14309/pgp00000.pgp
Description: PGP signature

Reply via email to