On 7/4/06, jan gestre <[EMAIL PROTECTED]> wrote:

On 7/3/06, Kent Stewart <[EMAIL PROTECTED]> wrote:
> On Sunday 02 July 2006 14:23, Jim Stapleton wrote:
> > I would guess that means the file was corrupted somehow, though I
> > don't know how.
> >
> > At any rate, I don't know how to fix that, and not loose the stored
> > information.
> You "pkgdb -fu" and it recreates the database. You will also probably
> find that you need to recreate your INDEX[-*].db. After that,
> everything works just fine. All I did is run pkg-version and it rebuilt
> the INDEX.db.

i 'm having this same problem :(  tried everything that is mentioned in
here but to no avail. i even tried make deinstall and make reinstall and it
didnt work, pkg_delete wont work coz it cant find portupgrade. pls help

i fixed the problem, i saw a solution in one of the threads and it is now
ok. here is what i did:

# cd /var/db/pkg/
# mv pkgdb.db pkgdb.db.orig
# pkgdb -fu

everything went back to normal, portupgrade port was the problem as stated
by the maintainer.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to