Thu, 6 Jul 2006 08:43:05 -0400, Joe Auty wrote:

> As of the latest portupgrade upgrade I'm getting the following error
> message when I try to invoke and of the portupgrade scripts:

> # pkgdb -F
> /usr/local/lib/ruby/site_ruby/1.8/i386-freebsd5/bdb.so:
> (NotImplementedError)
> BDB needs compatible versions of libdb & db.h
>         you have db.h version 4.1.25 and libdb version 4.3.29
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:152:in
> `set_db_driver'
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:81:in `setup'
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:76:in
> `initialize'
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:5:in `new'
>         from /usr/local/lib/ruby/1.8/singleton.rb:95:in `instance'
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:206:in
> `init_pkgtools_global'
>         from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:1155
>         from /usr/local/sbin/pkgdb:36


> I've tried deleting db43, and while this changed the error message,
> I'm still having problems. Before I start randomly deinstalling and/
> or reinstalling anything this, is there a smart way to fix this
> problem?

 Solution for fix this error described in ports/UPDATING file. Read this!

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to