Frank Jahnke <[EMAIL PROTECTED]> writes:

> I use a few Linux programs on FreeBSD, and sometimes they invoke other
> programs that use command line options. I have never been able to get
> this parameter passing to work. 
>
> For example, PDF files read by Acroread can contain links to a web
> browser or an email program; these are often invoked as "program-name 
> %s" in the set-up file. VMware does the same with invoking a browser
> from defaults set in a config file.
>
> I am able to get the appropriate program to open, but the parameters are
> never passed. I have tried many, many schemes to quote or escape the
> command and its options, but never have any of these worked.
>
> Any suggestions on how I might do this would be most appreciated!

Hmm.  Works for me.  A web link in a PDF in Acroread (7) brings up the
linked page in my (native) firefox.  I had to configure the executable
name (without path) into the "browser link" preference in acroread,
and I think the .mailcap entry ("text/html; firefox %s") is needed as
well. 
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to