Hi all,

I got some problems with mounting my usb device. I did all the stuff according to point 9.22 in the FreeBSD FAQ, but I still cannot mount my usb storage key (a sandisk cruzer mini 256 MB) as an ordinary user, without having to change the group owner as a root. Adding the needed lines to devfs.conf doesn't seem to help in retaining the settings across multiple reboots. I run FreeBSD-stable 6.1

in /etc/sysctl.conf I added:

I added to my etc/devfs.conf the following lines:
own     /dev/da0s1      root:usb
perm    /dev/da0s1      0666

I added myself, the ordinary user to the group usb and checked if that worked out by doing id $myusername:
uid=1002($myusername) gid=0(wheel) groups=0(wheel), 1002(usb), 1004(cvs)

so I am in the group usb, and if everything went allright, also the folder /dev/da0s1 should now owned by the group usb. So I'll reboot and plugin the device.

I reboot and plugin my usb key. Check if things are recognized using usbdevs:
$ devfs
addr 1: UHCI root hub, Intel
addr 2: product 0x3108, vendor 0x04b3
addr 1: UHCI root hub, Intel
addr 2: Cruzer Mini, SanDisk Corporation
seems it has been recognized. Now I check the user rights on dev/da0s1

$ su
$ ls -aln /dev | grep da0
crw-r-----   1 0     5       0, 107 Jul  8 15:17 da0
crw-r-----   1 0     5       0, 108 Jul  8 15:17 da0s1
crw-r-----   1 0     5       0, 108 Jul  8 15:17 da0s1

alas, despite the changes made in devfs.conf, the group in which da0s1 is in, is still another one than the usb-group (which has 1002) as a group identifier. So still not able to mount the device as an ordinary user.

anybody advice on how to tweak my devfs.conf, so that it works?


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to