On Wednesday 12 July 2006 17:47, Neil Short wrote:
> This is a problem on a home-built computer using an
> nVidia nForce4 motherboard.
>
> IDE 1 and 2 each have two devices.
>
> IDE 1 master: a Maxtor hard drive (jumpered to master)
> IDE 1 slave: a CDRW (jumpered to slave)
> IDE 2 master: CDRW (jumpered to master)
> IDE 2 slave: CDRW (jumpered to slave)
>
> So, when I do something intense - like build a new
> kernel or buildworld - I start getting the following
> in stdout:
>
> <snip>
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006527
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006527
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006655
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006655
> g_vfs_done():ad0s1f[WRITE(offset=253247242240,
> length=131072)]error = 5
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006527
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006527
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006655
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006655
> g_vfs_done():ad0s1f[WRITE(offset=253247242240,
> length=131072)]error = 5
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006527
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006655
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006655
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006527
> g_vfs_done():ad0s1f[WRITE(offset=253247242240,
> length=131072)]error = 5
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006527
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006527
> ad0: WARNING - WRITE_DMA48 UDMA ICRC error (retrying
> request) LBA=505006655
> ad0: FAILURE - WRITE_DMA48 status=51<READY,DSC,ERROR>
> error=4<ABORTED> LBA=505006655
> g_vfs_done():ad0s1f[WRITE(offset=253247242240,
> length=131072)]error = 5
> <snip>
>
>
> Now, interestingly, if I unplug the CDRW that uses IDE
> 1 slave, everything works fine.
>
> But for my needs, I need three CDRWs.
>
> Questions:
>
> I have noticed a lot of Internet chatter about this
> kind of thing happening with similar configurations on
> WinXP. Using the generic XP IDE driver seems to fix
> it.
>
> Could this be a problem with FreeBSD?
>
> Do you think it would be a dumb idea to try to run
> either the hard drive or one of the CDRWs from one of
> the available SATAs?
>
>
>
> ======
> Now I, Nebuchadnezzar, praise and extol and honor the King of heaven, for
> all his works are truth, and his ways are justice; and he is able to bring
> low those who walk in pride. Daniel 4:37
>

if you have access to one of those converter dealies, that you can put an ide 
drive on an sata channel, then i would give that a shot.  my system is on an 
sata drive (FreeBSD 6.1-STABLE) and performance is quite satisfactory.  even 
if it performs with the same speed as any other IDE drive... at least you 
will have seperated your cdroms from your disk's data path.

hth,
jonathan
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to