On 07/13/2006 06:50, Boris Samorodov wrote:
(maintainer CCed)

On Wed, 12 Jul 2006 11:26:36 -0500 Eric Schuele wrote:

I am trying to get a linux app to use hardware acceleration.  I have a
couple of linux apps (googleearth, NWN) that *do presently work* with
hardware acceleration... but this one in particular (linux-ut) *does

Which version of linux-ut you are running?

linux-ut-451                =  [held] up-to-date with port

Though, I don't think that is in the ports tree yet. Sean sent it to me directly, after he made the port.

I asked him about getting hardware acceleration up and running.... and we were not able to figure it out. Though the message below is more descriptive now (in the 451 build) than it was when I asked him previously.

It gives me the following error in its log file:
Critical: Failed loading /usr/compat/linux/usr/X11R6/lib/libGL.so.1:
lib/libdrm.so.2: ELF file OS ABI invalid

It's really strange that only linux-ut doesn't work.

I agree.

Eric, are you sure that you don't have any non-standard paths, LD_* or
something else at your environment which ends up with searching
/usr/local before /compat/linux for linux-ut?

No, I'm not exactly. If I modify /usr/local/bin/ut so that it echoes LD_LIBRARY_PATH right before it launches the game I get the following:

  LD_LIBRARY_PATH = :/usr/local/share/linux-ut/System

which looked odd.

So I tried the following two, and neither worked.
LD_LIBRARY_PATH = :/usr/compat/linux:/usr/compat/linux/usr/lib:/usr/local/share/linux-ut/System LD_LIBRARY_PATH = /usr/compat/linux:/usr/compat/linux/usr/lib:/usr/local/share/linux-ut/System

Both end up with exactly the same error message.

I tried to run /usr/compat/linux/usr/bin/ldd on /usr/compat/.../libGL but it gave no output!? Is that correct?

Is my linux libGL.so.1 trying to use my FreeBSD libdrm.so.2?  Surely
that's not what is supposed to happen?

I have:
FreeBSD 6.1-STABLE i386 as of a few days ago.
linux-atk-1.9.1             =  up-to-date with port
linux-expat-1.95.8          =  up-to-date with port
linux-fontconfig-2.2.3_5    =  up-to-date with port
linux-glib2-2.6.6           =  up-to-date with port
linux-gtk2-2.6.10           =  up-to-date with port
linux-jpeg-6b.34            =  up-to-date with port
linux-openmotif-2.2.4_2     =  up-to-date with port
linux-pango-1.8.1           =  up-to-date with port
linux-png-1.2.8_2           =  up-to-date with port
linux-realplayer-  =  up-to-date with port
linux-sdl-1.2.10_1          =  up-to-date with port
linux-tiff-3.7.1            =  up-to-date with port
linux-xorg-libs-6.8.2_5     =  up-to-date with port
linux_base-fc-4_6           =  up-to-date with port
linux_dri-6.5               =  up-to-date with port
linuxdoc-1.1_1              =  up-to-date with port
linuxpluginwrapper-20051113_4  =  up-to-date with port

What else can I provide that might be of use?  Any ideas?


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to