Bill Moran <[EMAIL PROTECTED]> writes:

> On some Dells, there is a BIOS option to boot with "USB legacy support"
> (or some similar wording) or without USB support at all.  Having the
> correct setting is pivotal to getting the USB keyboard to work.  The
> correct setting varies from model to model.  What fun.

I didn't see any option like this on my Dimension 9150. :-(

> Additionally, sometimes escaping the boot loader and setting
> hint.atkbd.0.flags="0x1" is still required on some hardware (even with
> 6.1).

I'll look into this.

> That might be faster ... get a FreeSBIE disk.

Tried this, very nice LiveCD.  But I couldn't figure out how to get it
to see and then mount my SATA disk partition so I could fix its
/etc/fstab.  Perhaps I missed something, but the
/scripts/ didn't seem to find the hard drives.

Alex Zbyslaw <[EMAIL PROTECTED]> wrote:

> The FreeBSD installation CD will also do just fine with fixit shell.
> Any CD from 5.X onwards should mount UFS2 partitions even if you are
> running some later OS version.  Given your USB trouble, a 5.X CD might
> even be preferred since it has the boot option you want.

Since I couldn't figure out how to get FreeSBIE to mount the hard
drives, I started downloading the FreeBSD-6.1 install CDs.  While
waiting, I got the dead box to boot over the net from my main box
(which boots a small diskless box I run in the kitchen).  That at
least brought it up to the point where I could ssh into the box then
fix the /etc/fstab.

Kinda round-about but it worked.  :-)

Erik Nørgaard <[EMAIL PROTECTED]> wrote:

> The keyboard usually works on the boot menu as the bios is in control.
> So, exit the menu to load the kernel modules you need, usb, ukbd and
> uhid I think should do. Then boot into single user mode.

I tried this, but when it started to boot it said the modules were
already installed and then hung at the point where it sees "atkbdc0".

> For next time, this happens, I suggest you build a kernel with usb
> keyboard support built in. I think the GENERIC kernel now supports usb
> keyboards by default, which explains why the boot option has been removed.

I'll check to make sure my custom kernel has this.

Thanks to everyone for your help.
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to